Nexus player sponteneous reboot soon after loading/playing graphic intensive games

John Semler

Member
Dec 2, 2013
8
0
0
Visit site
Can't play Asphalt 8, Red Bull Air Racing and that Dune Buggy game (I don't remember the exact game titles). Is anyone else having the same problems? I tried the factory reset to see if the problem will go away. I am using the ASUS Game Pad for the Nexus Player.

I fear I may have a bad unit.
 

renegad3

Well-known member
May 16, 2013
159
0
0
Visit site
Same for me, I called google, they are sending me a new unit.

Some others on XDA also had the issue, called, got new units, and they report them working fine.

Mine should be here next week.
 

ssbean

New member
Jun 10, 2011
1
0
0
Visit site
Is your replacement device working? Having this same issue with some of the same games. Just called Google and the rep I talked to said it was the first time he had gotten a call about the issue, said it was likely an issue with the app itself that the developers needed to fix. Everything else on the device works fine (music, YouTube, etc.), so I'm inclined to believe the rep. But if others have reported that the issues go away with a new device, I'm wondering where the gap might be.
 

John Semler

Member
Dec 2, 2013
8
0
0
Visit site
Got my replacement device last night. Watch a movie and played a TV show on NetFlix. No Audio dropout! Played Asphalt 8, Dune Buggy Racer and several other games tonight. No more spontaneous reboots!

Keep the unit plugged in when you contact technical support. Just allow them to go through the troubleshooting procedure with you. In my case, it was easy to demonstrate there was nothing further I could try on my end. I swapped the HDMI cable to another port on my TV and fired up Asphalt 8. It rebooted before I even had a chance to start the tutorial.

XDA forum is a little more active on the subject of audio dropouts and spontaneous reboots when playing games.
 

Lee_Bo

Well-known member
Apr 4, 2010
929
58
28
Visit site
My unit isn't rebooting, but it did lock up after about 2 hours of Asphalt 8. I had to disconnect power and reconnect. The unit did feel extremely warm when it locked up. So far that's the only time it's done that.
 

Trending Posts

Forum statistics

Threads
941,387
Messages
6,908,489
Members
3,157,894
Latest member
greggplu