Not able to connect to 4G LTE! ?

STARGATE

Ambassador
Oct 8, 2012
6,660
62
48
Visit site
So last week I noticed my Galaxy S4 was not connecting to Sprint's 4G LTE where my previous GS4 did.

Sprint tech support said they're upgrading the antennas around here, but the Sprint store close to my house has a GS3, G Note, HTC One and other LTE phones connected to 4G LTE :confused:

Last Wednesday I exchanged that phone for this other GS4 but the problem persists!

I just want to know if someone else had experienced the same problem. I'm regularly in Cary, Raleigh and Morrisville NC.

Thanks in advance.

Sent From a Galaxy S4 Away!
 

Mellimel22

Banned
Mar 1, 2012
2,447
41
0
Visit site
Maybe the towers around the store is already upgraded. Or the store has a repeater.

Sent from my T-Mobile LG Escape using Tapatalk 2
 

Speedy3

Active member
Jul 9, 2011
37
0
0
Visit site
It's your service provider. I went with my cousin to Sprint in Cary because her "Capital Letter" Phone 5 would not download apps or open them. They gave her the story about the upgrading of towers.....dada dada dada. Funny thing though was the look on the guy's face when she told him that her "Capital Letter" Phone 5 that is issued by her job on Verizon does all of the same tasks without any issues. I told her if it were me I would ask for a credit on my bill because she is paying for a service that she is not receiving. I'm not disparaging Sprint but that's why I chose Verizon and don't complain or care about having to pay more for a service that works.
 

STARGATE

Ambassador
Oct 8, 2012
6,660
62
48
Visit site
Thanks for answering guys!

In my account I also have 2 GS3 phones and a HTC One and wherever they get 4G LTE I don't! :banghead::confused:

Sent From a Galaxy S4 Away!
 

Mellimel22

Banned
Mar 1, 2012
2,447
41
0
Visit site
Thanks for answering guys!

In my account I also have 2 GS3 phones and a HTC One and wherever they get 4G LTE I don't! :banghead::confused:

Sent From a Galaxy S4 Away!

Maybe u need to do a prl update and update your profile. If that don't work then maybe u have a bad unit.

Sent from my T-Mobile LG Escape using Tapatalk 2
 

STARGATE

Ambassador
Oct 8, 2012
6,660
62
48
Visit site
Maybe u need to do a prl update and update your profile. If that don't work then maybe u have a bad unit.

Sent from my T-Mobile LG Escape using Tapatalk 2

Done. And done.
Even Sprint reprovision the phone yesterday. Nothing! :banghead:

Man I feel bad! Second Galaxy S4 on Sprint from Best Buy that has this problem!

I never had that much bad luck with a phone, not even my beloved, launch day Palm Prē!

Sent From a Galaxy S4 Away!
 

pynkfloydd

Member
Apr 27, 2012
10
0
0
Visit site
I would double-check your sim card as it's required for LTE. Also verify its number on your Sprint account online. I bought my S4 on eBay and had to hunt down a sim card for LTE because it was missing the one that came preinstalled.

I've also been getting connection errors in certain areas. Once I get home, they're gone. I noticed that this didn't happen until around the time that they announced TDD-LTE availability in the Chicago area recently. It could also be just because of tower upgrades. I was unable to receive texts for about a month last year because of tower upgrades. I moved to NY before they fixed everything, but am visiting home (in the Chicago area) and service here is excellent now. You can actually call customer service to check if there are any open work orders on towers in your area and when they're scheduled to be completed.

Edit: Just noticed that you said it's from Best Buy and your second one. It's very likely that your service rep isn't entering the sim card into your account. Without it, you can't get LTE.
 

STARGATE

Ambassador
Oct 8, 2012
6,660
62
48
Visit site
Edit: Just noticed that you said it's from Best Buy and your second one. It's very likely that your service rep isn't entering the sim card into your account. Without it, you can't get LTE.

I fail to say I actually spoke with 3 different people on Sprint on the other GS4 and with this second GS4 I have talked to 4 different people and they all agreed everything is the way is supposed to be.

At this point I feel I'm gonna have to go back to best buy and try to exchange it.

Sent From a Galaxy S4 Away!
 

Almeuit

Moderator Team Leader
Moderator
Apr 17, 2012
32,277
23
38
Visit site
I fail to say I actually spoke with 3 different people on Sprint on the other GS4 and with this second GS4 I have talked to 4 different people and they all agreed everything is the way is supposed to be.

At this point I feel I'm gonna have to go back to best buy and try to exchange it.

Sent From a Galaxy S4 Away!

Before doing that make sure your phone is set to use LTE if it sees it. Go to settings, mobile networks, and ensure it is set to CDMA / LTE and not just CDMA. This very well could be the issue if your other phones are getting the LTE connection but your S4 isn't.

Sent from my T-Mobile HTC One using AC Forums.
 

STARGATE

Ambassador
Oct 8, 2012
6,660
62
48
Visit site
Before doing that make sure your phone is set to use LTE if it sees it. Go to settings, mobile networks, and ensure it is set to CDMA / LTE and not just CDMA. This very well could be the issue if your other phones are getting the LTE connection but your S4 isn't.

Sent from my T-Mobile HTC One using AC Forums.

Hello Almeuit, it's been a long time.
Thanks for the tip, I've done that since the first day, I've actually done everything I know and stuff I didn't know. Sprint tech support was very surprise at this problem too. My phone was reprovision and they checked it like 4 times and all seems good, except for the part were I don't get any 4G LTE!:confused::eek:

Sent From a Galaxy S4 Away!
 

gollum18

Well-known member
Oct 10, 2011
1,485
32
0
Visit site
Hello Almeuit, it's been a long time.
Thanks for the tip, I've done that since the first day, I've actually done everything I know and stuff I didn't know. Sprint tech support was very surprise at this problem too. My phone was reprovision and they checked it like 4 times and all seems good, except for the part were I don't get any 4G LTE!:confused::eek:

Sent From a Galaxy S4 Away!

If it still isn't connecting toggle airplane mode on and off. This will force your radios to rescan and hopefully connect you to 4g. The reason you would need to do this is because both the s4 and 3 are set up to scan for a 4g signal every 30 minutes to save battery life, as scanning really tears it up. You would want it to scan immediately to pick it up, so you aren't waiting to connect.

Also after you set it to cdma/lte did you reboot your phone? This is necessary on touchwiz ROMs for the setting to actually change.

Sent from my SPH-L710 using Tapatalk 2
 

STARGATE

Ambassador
Oct 8, 2012
6,660
62
48
Visit site
If it still isn't connecting toggle airplane mode on and off. This will force your radios to rescan and hopefully connect you to 4g. The reason you would need to do this is because both the s4 and 3 are set up to scan for a 4g signal every 30 minutes to save battery life, as scanning really tears it up. You would want it to scan immediately to pick it up, so you aren't waiting to connect.

Also after you set it to cdma/lte did you reboot your phone? This is necessary on touchwiz ROMs for the setting to actually change.

Sent from my SPH-L710 using Tapatalk 2

Thanks, I've done all that. I actually have done everything that has been said here. Unfortunately nothing has helped.

Sent From a Galaxy S4 Away!
 

STARGATE

Ambassador
Oct 8, 2012
6,660
62
48
Visit site
Everything seems fine, I been checking every single day. :banghead:

As soon as I have time I'm going to head over to best buy and exchange this thing! :mad:

Sent From a Galaxy S4 Away!
 

Almeuit

Moderator Team Leader
Moderator
Apr 17, 2012
32,277
23
38
Visit site

Craig Rogers

Banned
Jan 8, 2013
128
0
0
Visit site
Sprint has more problems than any other major carrier. They have network issues like crazy and their systems suck (sorry I'm not trying to hate on sprint, I'm just pointing out some things). My friend has sprint and his service sucks everywhere, but AT&T along with Verizon are excellent here . It's sprint, something on their end. Switching the phone should help, but it's sprint for sure. You get what you pay for, I promise you won't have these problems on AT&T or Verizon. Sorry for the hate ramble, but that's just my opinion of sprint

Sent from my wonderful completely customized galaxy s3 running CyanogenMod 10.1.2
 

Forum statistics

Threads
943,840
Messages
6,920,276
Members
3,159,255
Latest member
atlantisx