Note Edge w/ Lollipop - stop Calendar notifications

Dave-in-Decatur

Well-known member
Feb 4, 2012
387
7
0
Visit site
I just bought a Note Edge from Verizon, and I love, love, love it. It upgraded to Android 5 Lollipop right after I got it. I'd had Lollipop on my S4, so I was aware that there are a few little quirks. So far the most annoying has to do with the stock Calendar app. I never use it, preferring to use Business Calendar 2. I want to get notifications for events from BC2, but not from stock Calendar. In Calendar's settings, I cannot find a way to turn notifications completely off. I can set the notification alert to Off and the Notification sound to Silent, and turn off vibration. But every time there's an event, I get a brief fragment of the Calendar default notification sound, followed by the sound I've chosen in BC, and a notification from both apps in my notification bar.

I have force-stopped and disabled Calendar (size of 1.61MB) in Application manager (as well as unchecking Show notifications in it). There are two other Calendar entries in Application manager. One of these is Calendar storage (4.54MB); I tried disabling that, but then BC couldn't display any events; I did uncheck Show notifications in it. The other entry is also labeled just Calendar (15.34MB), and while I can force-stop it, it can't be disabled, and even the Show notifications box is checked but dimmed so that it cannot be unchecked. Even if I force-stop this one, I still get stock Calendar notifications.

It seems as if stock Calendar in Lollipop, on this device at least, must be allowed to run and send notifications, whether the user desires it or not. Can anyone give me an idea how to get around this?
 

dmcduck

New member
Jun 21, 2010
2
0
0
Visit site
Go into Calendar. Pull out the side menu. Scroll down to Settings. Tap General. Turn off "Notify on this device"

Hope this helps.
 

Dave-in-Decatur

Well-known member
Feb 4, 2012
387
7
0
Visit site
Thanks. Unfortunately, though, that doesn't apply. On this version of Calendar, the side-pull menu (also accessible from a hamburger stack in the top left corner) only has options for what is to be displayed (year, month, etc.). Settings is on a menu accessed from the 3-dot menu icon in the top right (or the Menu key, if the phone has one); and Settings has no General area. It has View settings (what to show or hide); Time zone; and Event notification, in which I've set the items indicated above, which seem to be completely ignored.

FWIW, for another reason I did a battery-pull restart today, and that had no effect on this issue.
 

Dave-in-Decatur

Well-known member
Feb 4, 2012
387
7
0
Visit site
The problem persists, and I begin to believe it is a flaw in Samsung's implementation of the Android 5 stock Calendar. Most other versions of this stock app have a setting for turning off notifications. This one just does not. I still have my previous phone, a Galaxy S4 also with Android 5, and its Calendar app also lacks this setting. I'd love to hear from anyone who's been able to turn these notifications off--specifically in a Samsung device running Android 5 Lollipop.
 

Trending Posts

Forum statistics

Threads
941,311
Messages
6,907,940
Members
3,157,860
Latest member
rlipso2434