Notification sounds play only through headphones and bluetooth

4thandKingSF

Member
Oct 27, 2022
9
0
0
Visit site
Good morning,

Newbie to this site and appreciate any help you can offer.

I have a Samsung S10+ on Verizon, running Android 12 and never had any issues with the phone. I recently had the battery professionally replaced by a Samsung authorized vendor to get one more year (or two) out of the phone and now the notification sounds do not play through the phone's speakers.

In the Sounds and Vibrations / Notification sound, when I select any sound file, it will not play through the speakers. If I go to the Ringtones, all of them will play. In the Volume section, if I alter the Ringtone volume, I'll hear that sound...then if I alter the Notification it will play once and won't make a sound after that if I change the volume setting again.

However, all of these sounds will play as usual through headphones or Bluetooth ear buds.

I did check the Do Not Disturb and it is off. I downloaded the Sound Assistant on the Galaxy Store and the Alerts through Headphones setting is off under the Advanced Setting. All the notification settings look normal.

Did I miss a setting somewhere that is playing the notifications through wired headphones/Bluetooth buds and not the phone speaker?

Thank you!
 

4thandKingSF

Member
Oct 27, 2022
9
0
0
Visit site
Yes, it does. All media and ringtones play through the speakers. It's only the notifications that are silent. The phone does vibrate when they come in (since I have the Vibrate while ringing active).
 

4thandKingSF

Member
Oct 27, 2022
9
0
0
Visit site
I am in safe mode now, and the ringtones and media play through the speakers but still no sound for notifications. What else should I check in safe mode?

Thank you again for the help!
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
90,750
5,422
113
Visit site
Welcome
That's all u can test in safe mode , you can exit out by restarting your device. You using any custom notification sounds or just the stock default?

Sent from my SM-F936U1 using AC Forums mobile app
 

4thandKingSF

Member
Oct 27, 2022
9
0
0
Visit site
It's a mix of stock and custom downloads, with the custom files mostly from Zedge. Even the stock sounds won't play...unless I have ear buds or wired headphones on, then they play like normal. I've never seen this before.

On the Sound Assistant app info, under Permissions, it says No Permissions Allowed, but there's no way to change it.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
90,750
5,422
113
Visit site
Screenshot
2719461b72f1b70b89f95404a53c9dfb.jpg


Sent from my SM-F721U1 using Tapatalk
 

4thandKingSF

Member
Oct 27, 2022
9
0
0
Visit site
So just uninstalled and no change. Phone will not play custom or stock notifications. I did capture the settings of the Sound Assistant in case something was wrong there.

EDIT: Under Permissions, it said No permissions allowed. (Not able to add the image)
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
90,750
5,422
113
Visit site
So just uninstalled and no change. Phone will not play custom or stock notifications. I did capture the settings of the Sound Assistant in case something was wrong there.

EDIT: Under Permissions, it said No permissions allowed. (Not able to add the image)
Permission I had microphone enable

Did u do a phone reboot?

If same then we move to next thing go to , setting>general management>reset>reset setting
 

4thandKingSF

Member
Oct 27, 2022
9
0
0
Visit site
I did perform the reboot with no change. I reset all the settings in the general management section and went right into the Sounds section when the phone restarted. Tested the stock notification sound and nothing through the speakers. The notifications still only play through the wired headphones (and probably Bluetooth buds, but didn't check those). I kind of hoped the reset would fix it.

I feel like there's some setting buried somewhere that I'm not checking.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
90,750
5,422
113
Visit site
I did perform the reboot with no change. I reset all the settings in the general management section and went right into the Sounds section when the phone restarted. Tested the stock notification sound and nothing through the speakers. The notifications still only play through the wired headphones (and probably Bluetooth buds, but didn't check those). I kind of hoped the reset would fix it.

I feel like there's some setting buried somewhere that I'm not checking.
Yeah something not right for sure
Try settings>Apps>3 dots upper right corner tap>reset app preference

Sent from my Pixel 7 Pro using AC Forums mobile app
 

4thandKingSF

Member
Oct 27, 2022
9
0
0
Visit site
Yeah, the same. I can hear the notification sounds when texts/emails come in through the headphones, but when I unplug them, nothing from the speaker.

This is the craziest thing.
 

J Dubbs

Well-known member
Jun 4, 2016
4,006
1,139
113
Visit site
Yeah, the same. I can hear the notification sounds when texts/emails come in through the headphones, but when I unplug them, nothing from the speaker.

This is the craziest thing.

It's possible the shop that replaced your battery messed something up, since you said this started right after having the battery replaced.
 

4thandKingSF

Member
Oct 27, 2022
9
0
0
Visit site
Yeah, I thought of that too. Was hoping to find a buried setting somewhere I was missing and just correct from home. I'm definitely heading back there to talk to them since this was fine before the battery was replaced. (Won't do that again for future phones.)

Thanks!