• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues please let us know in this thread!

Odin gets stuck, Can't flash any firmware on my S3.


New member
Jul 14, 2014
Hello friends,

I'm having issues with my T-Mobile SGH-T999 Galaxy S3. The phone had stock firmware and it stopped working out of nowhere. So I started diggin' a bit... Seems it has the infamous "SDS syndrome". Now, it won't enter the recovery mode but I can enter the download mode. So I tried to flash it using Odin and stock firmware that I got from SamMobile. Odin says the phone has been added but the process stops at "Initializing" or "Setup Connection". I've turned off Kies, uninstalled my antivirus program, turned off firewall, tried all ports and different cable and also ran Odin as admin, tried different PC and it's the same... Initializing or Setup Connection. ONCE it managed to get to the point "NAND Write Start" but it stopped there... Also I keep the battery full while I'm running it. Any ideas or suggestions on what else I could try?



New member
May 26, 2015
Odin 3.07 or 3.09 (I tried both) is stuck on "initializing" and goes no further.

I start Odin, click on PDA and pull up the file I535VRUDNE1_I535VZWDNE1_I535VRUDNE1_HOME.tar.md5

then I put the S3 SCH-I535 in download mode and then I connect the usb cable, and then I click on Start and it gets stuck on initializing.

Any one know what the problem is? How do I get past "initializing"?