Off-contract Tbolt Died

Dirtman16

Well-known member
Mar 17, 2011
45
0
0
Visit site
So I'm running an off contract TBolt bought right after release. Today, it turned off by itself. Upon a reboot, the icons for Sense wouldn't appear. I restarted one more time and it only made it to the HTC boot screen. Following a battery pull, the phone would not restart at all. No bootloader, boot screen, nothing. The charge light will also not come on when the phone is plugged in (tried multiple charge cords)

I checked the battery with a meter and the voltage seems fine. So, I'm afraid I've got a difficult hardware fix. If it's important, I was running rooted with Sky Raider Zeus, but it had been working fine for several days before this.

Anyone have any advice or experience a similar situation? I'd like to revive it to wait for the S3 or the RAZR HD.
 

anon(394005)

Banned
Jul 5, 2011
1,914
162
0
Visit site
Definitely sounds like a hardware issue. Not sure what you could do with it though other than get a replacement. What ever is wrong with it will most likely require tools, test equipment, and knowledge that only HTC or an approved repair center would have.
 

worwig

Well-known member
Dec 29, 2010
990
50
0
Visit site
When you say the "voltage seems fine", what was it?
It should be greater then 3.5V. Hopefully closer to 4.2V.
 

Dirtman16

Well-known member
Mar 17, 2011
45
0
0
Visit site
Voltage was around 3.9 volts. I actually got the charge indicator to come on with the stock charge cable. It stayed lit for a few hours, then turned off and never went green.

I took the phone to Verizon today and tried a new battery without any success. It's a business line, so I'll have to wait until Monday to do anything else. Sounds like there's not much hope though.
 

Trending Posts

Forum statistics

Threads
944,422
Messages
6,922,765
Members
3,159,551
Latest member
Lawrick