"OK Google" not working after Android Pie update

mvpkreddy

New member
Aug 9, 2018
3
0
0
Visit site
First let me say "Essential" team has done an amazing job by releasing Android Pie as soon as Google released the version. So far, I am having good experience with Essential except for "OK Google". The device is not able to recognize my voice when I am going through setup. I tried with Cortana but still the same result. It worked before the Android Pie update (OOTB setup).

Is anyone having the same issue?
 

brybelle22

Well-known member
Sep 17, 2011
97
0
6
Visit site
I had that issue also. I disabled the Google app then when I enabled it I was able to reset my voice. Works normally now.
 

mvpkreddy

New member
Aug 9, 2018
3
0
0
Visit site
I tried that as well but still no luck. I uninstalled the "Google" app update, did factory reset etc but none of them works. I am surprised that Cortana and Alexa also has the same issue. I thought it was an issue with microphone but I tested with phone app and camera app and mic seems to be working fine.
 

jontalk

Well-known member
Feb 29, 2012
936
29
0
Visit site
First let me say "Essential" team has done an amazing job by releasing Android Pie as soon as Google released the version. So far, I am having good experience with Essential except for "OK Google". The device is not able to recognize my voice when I am going through setup. I tried with Cortana but still the same result. It worked before the Android Pie update (OOTB setup).

Is anyone having the same issue?

I'm hunting for one of these and in other discussions have found that issues are often tied to the color, believe it or not. So what color is yours? It seems the black was made first with some spotty QC problems, while the Halo Gray came last and appears to have fewer. Thanks
 

Loop28075

New member
Aug 11, 2018
1
0
0
Visit site
My gray version is doing the exact same thing, got it on Prime Day. I've factory reset several times to no avail, contacted Essential Support a week ago but they haven't responded. It did it on android 8 right out of the box and now on version 9. Looks like I'm sending it back unfortunately.
 

mogelijk

Trusted Member
Jul 14, 2013
929
0
0
Visit site
I'm hunting for one of these and in other discussions have found that issues are often tied to the color, believe it or not. So what color is yours? It seems the black was made first with some spotty QC problems, while the Halo Gray came last and appears to have fewer. Thanks

I have the Black, though mine wasn't one of the first built. Mine did not have the earpiece issue that was found in the early builds.
 

tech_head

Q&A Team
Aug 25, 2010
783
15
0
Visit site
First let me say "Essential" team has done an amazing job by releasing Android Pie as soon as Google released the version. So far, I am having good experience with Essential except for "OK Google". The device is not able to recognize my voice when I am going through setup. I tried with Cortana but still the same result. It worked before the Android Pie update (OOTB setup).

Is anyone having the same issue?

In settings, make sure "accessibility" is on.
 

Andrew_404

Well-known member
Jan 13, 2016
214
0
0
Visit site
Unfortunately, ok Google doesn't work while connected to my Bluetooth device. Works if I speak directly into the phone but through the car speaker module a no go.

My work phone works fine with me asking Siri a question, driving directions or current weather etc There's definitely a bug in the Bluetooth software or other.

I've tried another Android phone which is on Oreo 8.0 and 8.1 with success. So, Android 9 Pie has an issue.
 

ebrandwein

Well-known member
Nov 1, 2012
84
3
8
Visit site
Ok Google wasn't working for me until I went into Settings-Apps-Google-Storage and deleted everything. I then reactivated OK Google and re-recorded my voice. That seems to have fixed things
 

jontalk

Well-known member
Feb 29, 2012
936
29
0
Visit site
On a thread I posted about reliability and performance, another forum member mentioned he'd purchased a PH-1 and after installing Pie experienced many issues of which light leaks when watching YouTube videos was one, along with several others mentioned here. Light leaks sound more like a hardware problem than software, correct?
 

mvpkreddy

New member
Aug 9, 2018
3
0
0
Visit site
I identified the issue was with OOTB sticker covering the rear mic. I think prior to Android Pie update, the Google Asistant was using mic at the bottom of the phone whereas, after the update Google Assistant was using rear mic. I did setup Google Assistant finally but the hot detection is still not working.
 

Roosterman

Well-known member
Apr 3, 2011
372
54
28
Visit site
For Bluetooth not working, go to Google app settings>Google Assistant Sett>Devices Phone>Other voice settings. Turn on Bluetooth headset. Also, Google app settings>Google Assistant Settings>Devices Phone>Other hands-free device locked, turn on Bluetooth devices.