"Ok Google" to listen for command through my Bluetooth headset?

Vmdouglass

New member
Jan 16, 2017
1
0
0
Visit site
Is there a setting that allows the Pixel the option to listen for "Ok Google " command through the mic of my bluetooth headset mic instead of cell phone mic. Please help, it would make my Pixel experience so much better.
 
Last edited:

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,976
5,286
113
Visit site
Welcome to Android Central! Open the Google app, go to Settings>Voice>Hands-free, and make sure "Allow Requests with Device Locked for Bluetooth Devices" is turned on.
 

Go42

Member
Nov 21, 2016
21
0
0
Visit site
When I did this recently it drained my BT headset in about 1.5 hours. Normally I can use it for 5-6 hrs listening to audio or music or on a call.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,976
5,286
113
Visit site
I'm not sure if there are any other options. In order to respond to any Ok Google command, the Bluetooth headset presumably has to stay awake constantly, which then drains the battery faster.
 

gerrya

Well-known member
May 22, 2013
195
3
18
Visit site
I found that certain headsets just work without changing any settings when the call or send button is pressed on the headset itself, my Motorola HX550 works this way, when purchasing one, read the reviews, sometimes people say if the headset works with OK Google in the reviews.
 

SupermanJon707

Well-known member
Aug 6, 2014
75
0
0
Visit site
Is there a setting that allows the Pixel the option to listen for "Ok Google " command through the mic of my bluetooth headset mic instead of cell phone mic. Please help, it would make my Pixel experience so much better.

Just get a headset that supports it and you won't need to turn on setting to drain the battery
 

nvettese

Member
Aug 12, 2013
8
0
0
Visit site
When in Google Now, I go to Settings -> Voice
-> At the bottom, turn on "Bluetooth Headset"
-> Under OK Google Detection -- Make sure it is always on
-> Under Hands Free -- Turn on Bluetooth Devices
 

VikingOy

New member
May 10, 2014
2
0
1
Visit site
After the updated Google Assistant was released, all of the above is incorrect. Here's how you activate voice control using a wired or wireless headset:
1. Open Google Home
2. Click on your account symbol (the circle with a person inside)
3. Click on 'Settings' in the General Settings section
4. Select 'Assistant' from the tab row
5. Scroll down to find 'Assistant Devices' and click on your Phone
6.Click on 'Other hands-free settings
7. Select how you want Assistant to allow requests with device (your phone) locked

You have a choice of Bluetooth or wired headsets.
(It's amazing that Google managed to hide such a setting 7 levels deep down and away!!)
 

Eric Says

New member
Nov 19, 2019
1
0
0
Visit site
On my phone it's located Settings Gear icon>Google on the General Tab>Account Services>Search, Assistant & Voice>Google Assistant>Assistant tab>at the bottom is Assistant Devices> click + to Add that device. After that click it to modify more settings for that device, like Always-on Voice command.

This could be your Bluetooth device goes into power saving mode, and need to be woke with a button press, a more advance model device may always listen for the Google wake up commands, or a setting on the master device.

If not Try these:
https://support.google.com/headphones/answer/9027902?co=GENIE.Platform=Android&hl=en
https://support.google.com/headphones/answer/7520404?hl=en&ref_topic=7518050
https://support.google.com/googleplay/answer/113412?hl=en
https://support.google.com/assistant/answer/7283669?hl=en&ref_topic=7172845
https://support.google.com/assistant/answer/7394009?co=GENIE.Platform=Android&hl=en
https://support.google.com/assistant/answer/7394306?hl=en&ref_topic=7391797
 
Last edited:

J Dubbs

Well-known member
Jun 4, 2016
4,003
1,148
113
Visit site
My Jawbone headset works with "OK Google." No changes to settings, it just works.

Yep my last 3 phones, one running Android 7, one running 9, and now my pixel 1 running Android 10 work perfectly on the default settings with ok Google and my Bluetooth earpiece. All you have to do is hold down the call button until you hear 2 beeps, then let go and you'll hear a musical tone, after that start talking just like you would to the phone....no difference.
 

Forum statistics

Threads
944,563
Messages
6,923,373
Members
3,159,623
Latest member
omarkarsly