Only one app signs in to hotel internet

  • Thread starter Android Central Question
  • Start date
A

Android Central Question

Hi! I am traveling and staying at a hotel. You need to sign in to use the hotel's internet, which I did. Normally, I do so using my browser (Dolphin), but in this case it only worked if I used the built-in "Internet" app. When I signed in, everything on my phone worked fine.

Until I left the hotel to get food and came back. Now, the "Internet" app is still signed in and works fine. But the rest of my phone cannot connect to the internet (Dolphin, Facebook Messenger, my weather app, etc.). It seems like it is stuck waiting for the "sign in," but the "Internet" app is already signed in.

On Settings, the Wi-Fi just says "Connected" (it does not say "Sign-in to Use this Network" or whatever it would say).

I tried forgetting the network, but when I reconnected after that, the "Internet" app immediately was able to browse the entire web, while the rest of my phone is unable to connect to the internet.

My laptop has not had this issue, although I have not taken it out of the hotel like I have my phone.

Does anybody have any ideas for how to restore internet access to my phone? I can survive right now thanks to my laptop but it is hugely inconvenient for stuff like Google Maps, checking the weather, etc.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,738
4,907
113
Visit site
Welcome to Android Central! If your browser is set to use a custom DNS (like Google or Cloudflare), change it back to the ISP-provided DNS. I've recently found that this helps.
 

Forum statistics

Threads
943,839
Messages
6,920,270
Members
3,159,254
Latest member
roth4796