Optimus V lost root! Ack! Got my root back anyway.

Feb 19, 2011
1,971
284
0
Visit site
Yesterday I lost my root. Annoyed the h*** out of me.
I'd been rooted since the day I got my phone, the same day I opened an account here on this forum.
Been through 4 or 5 custom ROMs, never had any real problems except compatibility between the different recovery programs and specific ROMs.
Went back to the stock rom for whatever reason (and stock recovery, which was required to boot it, since clockwork mod for the V was stuck in a reboot-to-recovery loop after installing the stock ROM,) and had stayed rooted for a few days with that firmware, no issues.

Then, yesterday, I was testing another terminal app off the market...
Android Terminal by linxmap
I was going through the onscreen menus in that app, and my AdFree died. Ads started showing up! Ack! It took me a few hours to realize that my root was gone, when I tried 'adb remount system' and it told me 'permission denied.'
Fought with the beast for quite a while getting my root back, since I had f***ed up my Windoze install and couldn't get SuperOneClick to run in Ubuntu 10.10.
I did eventually get my adb root shell, but still couldn't run su through the handset terminal itself (permission denied.)
As soon as I got adb console root, I reflashed clockwork mod (recovery-clockwork-3.0.0.6-ov-20110220.img) and backed up my glitched system, then reflashed the Stock_Rooted_and_Optimized.zip from xda-developers. Seems all good now, holds through reboot.

Should it make any difference to someone with a similar problem, z4root and rageagainstthecage didn't work for rooting my device, either time. The first time I rooted, I successfully used SuperOneClick for the temporary shell root. The second time, when I had accidentally destroyed my MS Windoze install while setting up Ubuntu on my system, (and SuperOneClick required odd dependencies in Ubuntu that I couldn't apt-get,) I had no easy one-click-temporary console root for me this time.
To get this to work, I had to do the following. Bear in mind that I still had the software and files (Android SDK and its JDK dependencies, flash_image, su, busybox, recovery and ROM) which I used in my original rooting process, I just had to use Ubuntu instead of Windoze this time. A little tricky to track down all the documentation I needed, but eventually I simplified things down to this process:

I ended up extracting psneuter from the superoneclick.zip, doing a chmod right on my desktop hardware for the permissions
chmod 777 psneuter
then manually putting it on the phone with
adb push psneuter /data/local/tmp
did the same thing for su, flash_image, and busybox, set their permissions on my desktop machine and pushed them to the same directory
chmod 777 su
chmod 777 busybox
chmod 777 flash_image
adb push su /data/local/tmp
adb push flash_image /data/local/tmp
adb push busybox /data/local/tmp
and repeatedly using the adb shell to hammer at psneuter until it 'took' and gave me a root shell (# prompt instead of $) through adb. This took several tries.
adb shell
cd /data/local/tmp
./busybox psneuter
Eventually I got a root shell in adb, then I quickly moved su, busybox, and flash_image to /system/bin
mount -o remount,rw -t yaffs2 /system /system
cd /data/local/tmp
./busybox cp su /system/bin
./busybox cp flash_image /system/bin
./busybox cp busybox /system/bin
I had already put Stock_Rooted_and_Optimized.zip and recovery-clockwork-3.0.0.6-ov-20110220.img on my SD card's root directory, so next in the adb shell I reflashed the custom recovery
flash_image recovery /sdcard/recovery-clockwork-3.0.0.6-ov-20110220.img
rebooted the Optimus into recovery while still in the adb shell
reboot recovery
then I backed up my glitched system and flashed the Stock_Rooted_and_Optimized.zip.
It's all good again for now, but there's no chance I'm using that terminal app again! I can't say for sure that's what broke my root, but I was using it when the ads started flowing again. so, I don't trust it.
Maybe this'll help someone else.
links:
superoneclick is here
the other files and android SDK instructions are here
Stock_Rooted_and_Optimized ROM posted in this thread here
 
Last edited:

denshigomi

Well-known member
Feb 14, 2011
117
12
0
Visit site
That's strange. There is no race condition in psneuter. I wonder if something was rebuilding the ashmem map. Were you booted into Android or recovery?

As an F.Y.I., you don't need to run psneuter through busybox, like you did. I don't think that would have changed anything though.
 
Feb 19, 2011
1,971
284
0
Visit site
That's strange. There is no race condition in psneuter. I wonder if something was rebuilding the ashmem map. Were you booted into Android or recovery?

As an F.Y.I., you don't need to run psneuter through busybox, like you did. I don't think that would have changed anything though.

Was booted into android, only had the stock recovery and hadn't thought of using adb while in recovery at that time.
Running psneuter in the terminal app didn't work, so I ran it through busybox, until I was able to remount the root filesystem and flash_image a custom recovery. After flashing the recovery, it was easy. If psneuter wasn't responsible for getting my adb root shell back online, I really don't know what was going on. That wouldn't be too surprising since Android is rather new to me and I'm in it up to my armpits already. Fun, though, and I haven't fully bricked my device yet...
I've learned some since, found out the default.prop file in the phone filesystem root affects adb and the su blocking, and was also informed about the buildprop in the ramdisk being changeable for this as well. I've also noticed that with Xionia CWMA v1.2518.4 recovery, I can access as root through the adb shell while the phone is in recovery mode, even if I can't get su access in a terminal or adb while the phone is booted into android.

I have backed up the glitched install for experimentation, and have messed around with trying to salvage it a couple times since, but the root-enabled default.prop won't stick through reboot, and I haven't yet modified its ramdisk image to fix ro.secure there and see if it'll work. I've just ditched that install and tried to move on.

I'm completely open to more information than I've already accumulated. Thanks for responding.
 

Trending Posts

Forum statistics

Threads
943,886
Messages
6,920,483
Members
3,159,273
Latest member
MusicChris63