Oversaturation on the S7 Edge

EMGSM

Trusted Member
Apr 8, 2015
6,013
0
0
Visit site
When ever I go into a game, the screen goes into saturation mode. This happens even if I put the display on basic mode. As soon as I leave the game it automatically goes back to normal. Has anyone else experienced this?
 

TommyC1969

Member
Jul 4, 2012
19
4
0
Visit site
I don't have my GS7E yet (it is being delivered today), but my bet is that it is working as designed. I'm betting that Samsung assumes people to have the best visual experience when playing a game so the phone automatically switches into saturation mode when the game starts, and then reverts back automatically to whatever you had it set at before when you're done.

Having said that...it could also be a bug.
 

johmar228

New member
Mar 8, 2016
1
0
0
Visit site
You're not the only one. I've expended this last 3 days trying to figure it out, and I think I found the solution. (Need computer for this)

On your phone go to:
About device> Press several times on Build number (to activate Developer options)> go back to settings> turn on Developer options> turn on USB debugging.

On your computer:

Download and install:

Downloads for Mac:
Debloater.v.x.xx.dmg
Android.zip

Downloads for Windows:
Debloater.v.x.xx.exe
ADB for Windows

Install the app and drives, plug in your phone> open debloater> click read device (top left button)> click filter> type this in: GameOptimizer.apk> check it> click apply!

And since I did this I Can play normally on my S7, without that annoying over saturation.
 

madgalaxy

Well-known member
Mar 19, 2011
103
0
0
Visit site
Just got my S7 Edge today and it does the same when playing games. I do not like it cause I prefer my screen at "AMOLED Photo".
 
Jan 8, 2012
16
0
0
Visit site
So the solution is to disable the fancy Samsung game optimizer?? LOL Sucks that it came down to that, have you tried package disabler from the play store? Does all of that without having to connect to a computer...wondering if it works ok on the S7E (mines on the way today so still haven't had a chance to play yet.)

As a side note, I found it hilarious that the solution proposed wasn't to outright say "hey...need to disable the optimizer" rather the steps were outlined in detail as to how to disable it LOL.
 

madgalaxy

Well-known member
Mar 19, 2011
103
0
0
Visit site
I just tried Package Disabler from the play store and disabled "Game Service (com.enhance.gameservice) and it worked. No more oversaturation on games!
 

chanchan05

Q&A Team
Nov 22, 2014
8,519
0
0
Visit site
Doesn't happen to me, but I adjusted game tools to set the power saving game mode. I'm playing just CoC and CR and BB, all by Supercell. Those things don't need 60fps and all the power.
 

Forum statistics

Threads
941,494
Messages
6,909,147
Members
3,157,946
Latest member
doom44