• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

PC won't recognize lg x venture for MTP or ADB?

  • Thread starter Android Central Question
  • Start date

Android Central Question

Hello, I just purchased an LG X Venture, model number H700. It is running android 7.0. When I first got it a few days ago, I installed the drivers for it on my windows 7 computer, and plugged it in. I got a pop up on the phone where I set the default USB mode to MTP (media transfer protocol). It worked great, and I was able to tranfer files between my PC and my phone.

Then I tried to get adb debugging to work with my phone, and screwed everything up. I enabled developer options, and then checked USB debugging. I also accidentally hit the "revoke USB debugging authorization button." I installed what I think are the correct ADB drivers on my PC. Then I plugged my phone back into my PC. This time, nothing comes up. I've checked in the device manager, etc., and I can't find a trace of the phone anywhere.

I looked back at developer options under USB configuration, and it's still set to MTP. But somehow I screwed something up, because my phone and computer no longer recognize each other (except for charging).

I even tried my phone with two other computers (one also windows 7, the other mac), and got the same behavior.

Any idea how to fix this? Ideally I'd like to get ADB to work, but I would settle for just getting MTP back haha.