Perfect working one night ... Completely dead the next morning. Please help

initialscooby

New member
Aug 5, 2013
3
0
0
Visit site
Hello Android Central and Users ...

I am desperate here ... i cant believe this has happened and any help would be greatly appreciated.

Around 3 am i went to slept with my Mophie Charger Connected and charging. I woke up around 10 am and went to grab my phone (which i assume is fully charged) and it was off. I try and turn it on and nothing. it couldnt be dead .... but i tried charging it and nothing would happened. The battery was fairly new as i had just got a new one from Tmobile. I then swapped out batteries for the original battery and nothing.

I called tmobile. Tried troubleshooting (doing the holding power button for 15 seconds ... nothing .... holding volume up, power and home button ... nothing)

I called samsung ... they said the same things as tmobile said ... including one very strange option which included strangling my usb cord around my phone ...

NOTHING HAS WORKED thus far. I even connected it to a computer. Tried various usb cords and various chargers. NOTHING

Then one small light of hope happened yesterday ... With the phone plugged into a working charger (tested) .... i took the battery out and the led turned red (yes while the battery was out) ... i then tried to turn it on without the battery connected and nothing ... AS SOON as i plugged the battery back in ... the LED turned off and that never happened again ...

TMobile is sending me a replacement phone asap (it is backordered at the moment)

THE ONE THING THAT HURTS THE MOST ... AIRPORT CITY ... i have been playing the game for over 10 months now ... probably spent about $100 ... had a huge city ... and its now gonna be all gone!

I would do whatever to get this phone working again ..

NO ITS NOT ROOTED or NEVER HAS BEEN ... no physical damage either ... it has been my phone since about 2 weeks after release.

ANY HELP would be greatly appreciated .. THANKS IN ADVANCE.

-Jonathan
 

gollum18

Well-known member
Oct 10, 2011
1,485
32
0
Visit site
That's sounds like a short with the battery contacts on the inside of your s3. Try a spare battery if you have one, but that sounds like the issue and if it persists with the same issue, then its definitely the contacts. Of which you would need a replacement device, as they are soldered to the motherboard.

Sent from my SPH-L710 using Tapatalk 2
 

initialscooby

New member
Aug 5, 2013
3
0
0
Visit site
That's sounds like a short with the battery contacts on the inside of your s3. Try a spare battery if you have one, but that sounds like the issue and if it persists with the same issue, then its definitely the contacts. Of which you would need a replacement device, as they are soldered to the motherboard.

Sent from my SPH-L710 using Tapatalk 2

hey gollum,

i did try a spare battery ... no luck ... :(
any other suggestions ?
 

gollum18

Well-known member
Oct 10, 2011
1,485
32
0
Visit site
Hmm I would wait for the replacement phone then. As a motherboard replacement is quite complicated to do without professional equipment.

Hopefully airport city backs up your data somehow, perhaps with a user account? I'm sorry I'm unfamiliar with the game.

Perhaps you can take it into a T-Mobile store and see if they'll replace it, but I don't know how T-Mobile handles these situations as I'm on sprint.

Sent from my SPH-L710 using Tapatalk 2
 

Forum statistics

Threads
943,023
Messages
6,916,942
Members
3,158,785
Latest member
Paulm1407