Phone needs work.

milehigherik

Well-known member
Aug 30, 2012
660
0
0
Visit site
is LG ever going to address the slow connectivity issues across the board? Meaning.. every web-based application I use whether it be Facebook, Instagram or Gmail, basically every application that uses the internet is extremely slow for me. I should have never gotten rid of the pixel. Side by side comparison of two lgv20 phones did horrible compared to the pixel and also my girlfriend's S7 Edge witch has not had a factory reset for 6 months.

I've read others have the same issue. There was a fix that was posted that was basically just a workaround requiring you to disable location services by turning on battery saver mode. Why do I have to do that to get normal browsing speeds?

Other thing is the fact that the image is extremely processed after taking it creating a very granular effect when you zoom in on your photos that look so nice while they're zoomed out. I don't want to use manual mode.
 
Last edited:

Jeremiah Bonds

Trusted Member
Aug 16, 2010
3,151
0
0
Visit site
I don't have that web-based problem and I've never heard of it. Weird. I just checked all that you mentioned and they loaded fine for me. Not even a second to load. Sorry you're dealing with that.

Have you tried using a different camera app to test the sharpness when zooming in?
 

milehigherik

Well-known member
Aug 30, 2012
660
0
0
Visit site
Is this over your LTE connection? Or specific WiFi ones?

This is wifi and cellular. Tried a factory reset to no avail. Setup as a new device with no additional apps installed. I know Android very well and am perplexed by this. This is my 3rd V20 with the same issue. The other two were sent back in favor of the Pixel. Then I had issues with my pixel XL and gave up on it.

This phone lags like no other. I've tried different camera apps. No luck.
 

flyingkytez

Banned
Jan 28, 2011
3,368
0
0
Visit site
This is wifi and cellular. Tried a factory reset to no avail. Setup as a new device with no additional apps installed. I know Android very well and am perplexed by this. This is my 3rd V20 with the same issue. The other two were sent back in favor of the Pixel. Then I had issues with my pixel XL and gave up on it.

This phone lags like no other. I've tried different camera apps. No luck.

Which carrier are you using? Maybe we can help troubleshoot. The internet on 4GLTE/wifi works perfectly fine for me on my V20.
 

rcrc001

Member
Dec 21, 2016
23
0
0
Visit site
I would suggest checking the Network Mode to make sure you're not on Global.

From a Home screen, navigate: Settings Settings icon > More.
Note These instructions apply to Standard mode only.
Tap Mobile networks.
Tap System select.
Tap Network mode.
Select the appropriate setting:
Global
This is the preferred setting for most locations.
LTE/CDMA
This setting should only be selected if experiencing service issues in locations that offer multiple network types and only LTE/CDMA is needed.
LTE/GSM/UMTS
This setting should only be selected if experiencing service issues in locations that offer multiple network types and only GSM/UMTS is needed.
Note The preferred international carrier is automatically selected.
Note You can manually select an alternate carrier but it may require as many as 6 registration attempts with that carrier prior to successful registration.
 
Last edited:

Blues Fan

Well-known member
Jun 21, 2015
4,670
86
48
Visit site
I have tmobile and have the unlocked v20 though. Currently I switched back to my S7 edge and notice the internet is running a bit slower too. I'm wondering if maybe it's a network issue right now.
 

Almeuit

Moderator Team Leader
Moderator
Apr 17, 2012
32,278
22
0
Visit site
I have tmobile and have the unlocked v20 though. Currently I switched back to my S7 edge and notice the internet is running a bit slower too. I'm wondering if maybe it's a network issue right now.

I doubt it is a network issue since I doubt we all live in the same spot :p.
 

jmssarno

Well-known member
Jul 6, 2014
216
0
0
Visit site
I'm on T-Mobile as well and no connectivity issues to report. Although my selfies look pixelated when I zoom in....

Maybe I need to adjust the camera settings.
 

NoNoBadDog

New member
Feb 11, 2017
1
0
0
Visit site
I do not have that issue, and haven't heard of anyone else who has it on their V20. Where I work, my phone is faster than anyone's iPhone, and is on par with others' S7 phones.
 

milehigherik

Well-known member
Aug 30, 2012
660
0
0
Visit site
I'm on T-Mobile as well and no connectivity issues to report. Although my selfies look pixelated when I zoom in....

Maybe I need to adjust the camera settings.

I assure you that there is no fix in settings... I've tried every possible auto mode setting configuration.
 

KeepItReal

Well-known member
Feb 15, 2011
547
0
0
Visit site
Someone mentioned above about replacing the SIM card ? You may just be swapping the same card from phone to phone. Did you try this ?
 

milehigherik

Well-known member
Aug 30, 2012
660
0
0
Visit site
Someone mentioned above about replacing the SIM card ? You may just be swapping the same card from phone to phone. Did you try this ?

I wish it were as simple as a SIM card. I appreciate all the responses. However of the three units I have had all three have headache separate new SIM card.
 

Trending Posts

Forum statistics

Threads
941,515
Messages
6,909,219
Members
3,157,949
Latest member
KernelPanic