Phone won't vibrate even when set to "always"

schwars1

Well-known member
Dec 16, 2010
139
1
0
Visit site
Over the weekend I completed the software upgrade to 4.5.602 on my X and am pretty happy with it.

However, one strange issue has cropped up that I'm hoping can be easily resolved. I like to keep my phone in silent mode for 95% of the time - I don't want it to make a sound, ever, for anything. However, I do like it to vibrate for all notifications (phone, SMS, Gmail, etc.). In the past, I would put the phone in silent mode (either via the homescreen, under settings -> sound, or using the volume rocker) and select vibrate -> always under settings -> sound.

With same settings as always selected, my phone does not vibrate for any notifications. While this technically makes sense (silent = nothing), I just want my phone to vibrate and make no sounds. Is there a way to make this happen? I'm not even sure why the phone is behaving differently now...
 

schwars1

Well-known member
Dec 16, 2010
139
1
0
Visit site
Well, that was helpful as my texts and other miscellaneous notifications are vibrating again. However, Gmail notifications are still silent. What gives?
 

Ricky Babalu

BEACH BUM
Aug 30, 2010
1,927
168
0
Visit site
Well, that was helpful as my texts and other miscellaneous notifications are vibrating again. However, Gmail notifications are still silent. What gives?

I do not use Gmail. Is your Gmail up to date? I suspect you will have to try and clear the data for the Gmail application. If that does not work then try to uninstall the application then reinstall. Again, I do not use Gmail, but that is what I would do. BTW, be prepared to do this again because a new update is rolling out as we speak (could bring along more bugs).

DROIDX Update to 4.5.605 is on the Way, the Keyboard Bug is Finally Getting Fixed - Droid Life: A Droid Community Blog
 

schwars1

Well-known member
Dec 16, 2010
139
1
0
Visit site
Thanks for the tip about the Gmail app itself. I waited until I had time to SBF and apply the .605 update to deal with this issue.

Turns out the latest update for Gmail removes the options under settings for notifications (along with many other options). I had to rollback the app within the Market, change my notification settings, then update the app again. Very strange, and hopefully this can be fixed going forward.
 

2kcj

New member
Sep 30, 2011
1
0
0
Visit site
Hi, I'm brand new here, but I ran into the same issue when I upgraded. I figured out that they didn't remove it, they just moved it. Gmail now notifies per label - you have to go into the "Labels to notify" under Settings now, then setup notifications for each label that you might have. HTH.
 

schwars1

Well-known member
Dec 16, 2010
139
1
0
Visit site
I see, now, that they did just move those settings into a deeper sub-menu. I have Gmail notifications now, but I wonder why the upgrade turned them off?
 

Forum statistics

Threads
944,466
Messages
6,922,877
Members
3,159,570
Latest member
Anonymous Jones