Please help nexus 7 won't get passed x logo

mohimab

New member
Aug 26, 2013
2
0
0
Visit site
I recently turned my nexus 7 on and it wouldn't get passed the X logo. I have manually switched it off many times and tried again, however nothing changes. It seems to get worse each time as now everytime i try to manually switch it off, it just keeps restarting. I have also tried charging it for a few minutes, charging it for and hour and even more however it seems that lack of charge is not the problem. It just keeps getting stuck on the X logo while it is in the process of turning on. The weird thing about it is that it doesn't just freeze as the X logo is still in its usual motion of each colour on the X glowing (<hope you understand what I'm talking about there). Please help, what can I do?
 

Casey Mihal

New member
Aug 27, 2013
3
0
0
Visit site
I tried to reboot into recovery mode. When i did, it displayed no command, so i cant wipe the cache. I'm having the same problem as OP. It happened right after I installed the 4.3 update.
 

Casey Mihal

New member
Aug 27, 2013
3
0
0
Visit site
You can reboot and get into recovery mode by first turning off the nexus (hold down the power button for about 30 seconds). Then, hold down the volume down button and power button simultaneously. From there you can select recovery mode. However, my device's recovery mode would not work.
 

Casey Mihal

New member
Aug 27, 2013
3
0
0
Visit site
UPDATE!: I just did a factory reset to my nexus 7. It did work, but this will remove all of your personal data and will take it back to how it was when you bought it. This is the only thing that worked for me
 

Forum statistics

Threads
943,867
Messages
6,920,362
Members
3,159,268
Latest member
caroltheresa61