Please help. Samsung Galaxy S4 won't turn on.

Platuni

Member
Mar 13, 2014
9
0
0
Visit site
Hello, I have a problem with my Samsung Galaxy S4. I was playing games on my phone and decided to let my phones battery go to 0%. I then tried to charge my phone, but the problem is it keeps vibrating every 2 seconds and is not able to turn on. I have not tried a new battery as I have to order one but was wondering if it could be a different problem?

I have tried 2 chargers.
 

SAVAGE420

Well-known member
Sep 9, 2013
99
0
0
Visit site
Try pulling the battery out for a minute or so and try again.
You can try shocking it as well. But be careful.

Sent from my shed.
 

Platuni

Member
Mar 13, 2014
9
0
0
Visit site
Try pulling the battery out for a minute or so and try again.
You can try shocking it as well. But be careful.

Sent from my shed.

Already tried this. I don't want to try shocking it :confused:

I just want to know if it could be my battery or something to do with my phone. I think my battery
 

SAVAGE420

Well-known member
Sep 9, 2013
99
0
0
Visit site
Definitely your battery. Grab a new one they're cheap.
Let us know what's up when you try.

Shocking it is worth a shot anyways. It will be out of the phone when you do it. So no harm to the phone.
Good luck.

Sent from my shed.
 

Platuni

Member
Mar 13, 2014
9
0
0
Visit site
Definitely your battery. Grab a new one they're cheap.
Let us know what's up when you try.

Shocking it is worth a shot anyways. It will be out of the phone when you do it. So no harm to the phone.
Good luck.

Sent from my shed.

I've ordered one I will let you know soon as it arrives
 

Platuni

Member
Mar 13, 2014
9
0
0
Visit site
Ok first of all I want to say sorry for double post.

I got my new battery and it's working fine. Only problem is when I charge it the battery percentage goes down and not up, but says it's charging. What could be the problem?

Edit: I just tried turning my phone off to see if it would charge like that but it's still vibrating every 2 seconds. I also bought a new cable with the battery in case that was the problem.
 

SAVAGE420

Well-known member
Sep 9, 2013
99
0
0
Visit site
That's weird man.
When you say the percentage goes down, you say it goes into the negative past zero?
Only happens when phone on and plugged in?


Sent from my shed.
 

Sanjay Chandra

Well-known member
Jul 31, 2013
276
0
0
Visit site
Ok first of all I want to say sorry for double post.

I got my new battery and it's working fine. Only problem is when I charge it the battery percentage goes down and not up, but says it's charging. What could be the problem?

Edit: I just tried turning my phone off to see if it would charge like that but it's still vibrating every 2 seconds. I also bought a new cable with the battery in case that was the problem.

Take it to store and rectify it.

Its better.Don't waste much money on changing batteries and charger etc. because we don't know what's the problem.
 

Platuni

Member
Mar 13, 2014
9
0
0
Visit site
That's weird man.
When you say the percentage goes down, you say it goes into the negative past zero?
Only happens when phone on and plugged in?


Sent from my shed.

No sorry I didn't explain well.

For example my phone is on 58% battery and while it says it's charging the battery still goes down like now it's on 54%.4

Take it to store and rectify it.

Its better.Don't waste much money on changing batteries and charger etc. because we don't know what's the problem.

Yeah i'm going to bring it to a store if I can't fix it

Edit: I just tried my brothers charger and it's doing the same thing
 
Last edited:

yarnsrj

Well-known member
Oct 6, 2011
619
1
0
Visit site
Sounds like bad charging port. Does your charging port also have a lot of "wiggle" instead of fitting securely? The charge you're seeing is most likely what was on the new battery when you inserted it, and your charging port is not working properly. If using the toothpick to clean away any debris didn't help, then a Trip to the store is in order.

from "Ms Note 3" on Tapatalk
 

Platuni

Member
Mar 13, 2014
9
0
0
Visit site
Ok so I decided to do a hard reset today then I was going to take it to the store tomorrow.

I then went to charge my phone and there we go. It started charging. Somehow the hard reset worked!

Also my old battery which I replaced is also now charging.

Thanks for helping everyone :)

Edit: Soon as I type this it's doing it again. I give up! Taking it to the store tomorrow
 
Last edited:

Forum statistics

Threads
943,738
Messages
6,919,862
Members
3,159,202
Latest member
hooded88