Problem installing CM 10.1 on Nexus 4

Mateo1041

Member
Sep 6, 2010
17
0
0
Visit site
Hi all,

I have a Nexus 4 phone and rooted it once last year shortly after it came out. At that time I also put on a custom recovery. All worked pretty well using the Nexus Root Toolkit and there wasn't a whole lot I had to do on my end.

The recent Android 4.3 update had some issues, and after speaking with someone at work that uses CyanogenMod with his new Nexus 4, I figured I'd try that out too. It has not gone smoothly though and I'd love any help you can offer. :-( I heard that 4.3 needs to be re-rooted and so I felt I should just redo my prior steps.

So here's what I've done so far using the newest Nexus Root Toolkit (with Android 4.3 support):

* Performed the driver test. Successful.
* Clicked the unlock button. Phone is still unlocked from last time I believe, but I do not recall exact outcome. Seemed to go ok I think.
* Clicked the root button (with custom recovery option checked). My phone rebooted and it went through the steps, although I did receive one driver could not be installed error. Final outcome was that my phone rebooted into what I had before and nothing looked different about it. There may have been a "Waiting on device" error where it timed out after this reboot into what I had before.
* I booted into the custom recovery (either present from this time or last time) and wiped data/cache a few times. Then chose to install the stable CM 10.1 ROM. Seemed to go ok.
* I hadn't realized it did not include Gapps, so I pushed that file to the device using the Nexus Root Toolkit. I don't think it worked the first time, but it did the second (or so it seemed at least).
* Rebooted and see CyanogenMod is now installed. Problem is that the keyboard doesn't work and I get frequent brief pop-ups that disappear again. I see Google Play is installed, but not the other Gapps apps I'd expect. Some are there, others like Google Maps are not.

I'm at the point now where I've tried reinstalling the ROM after clearing data/cache, but outcome is the same with the weird CM behavior. I have not been able to get other files onto my phone to try flashing. Mount in the ClockworkMod custom recovery doesn't seem to do anything even though the boxes are checked. It feels like what I am installing is not fully sticking.

Any ideas? I'm just a bit disappointed as I thought this would be fairly straightforward like last time.

Thanks.
 

Trending Posts

Forum statistics

Threads
944,335
Messages
6,922,379
Members
3,159,501
Latest member
wyattling