Punctuation backspace

circustravis

Well-known member
Jun 18, 2010
108
2
0
Visit site
Apologies if this is addressed somewhere else. I searched and couldn't find anything on it.

Whenever I put in a lot of special characters like ", $, and a few others, my Droid 2 will backspace over the last space, and insert the character. To put the space back, I have to hit the left arrow twice, then space, then right arrow to the other side.

In case I'm not making sense, when I try to type:
Hey, dinner will cost $20

My D2 will make it:

Hey, dinner will cost$ 20

Does anyone know if there's a hack/fix for this?
 

RUSH

Well-known member
Dec 6, 2010
4,120
285
0
Visit site
... and you're sure you're pressing the space bar after -spelling cost?

In case I'm not making sense, when I try to type:

Hey, dinner will cost $20


My D2 will make it:


Hey, dinner will cost$ 20


Does anyone know if there's a hack/fix for this?
 

circustravis

Well-known member
Jun 18, 2010
108
2
0
Visit site
Correct. I hit the space bar, then $ and it will backspace and put the $ next to the word.

I've checked with 2 other D2 owners (one regular, one global), and it happens to them too.
 

RUSH

Well-known member
Dec 6, 2010
4,120
285
0
Visit site
Correct. I hit the space bar, then $ and it will backspace and put the $ next to the word.

I've checked with 2 other D2 owners (one regular, one global), and it happens to them too.
Since it seem like a known problem either for some or most, then most likely only an update could fix it.

Have you reported the issue to your carrier or manufacturer? If not, you should consider doing so.

Best of luck.
 

Rev2010

Well-known member
Oct 26, 2010
852
67
0
Visit site
I use a 3rd part keyboard app - Ultrakeyboard, and it this problem doesn't exist. Might not be a suggestion you're ok with but you may want to try a 3rd party keyboard app - Swiftkey and Smart Keyboard as said to be two of the top one's. To be honest, I find the built in auto correct absolutely horrendous so one of the first things I did was switch to a better keyboard app.


Rev.
 

circustravis

Well-known member
Jun 18, 2010
108
2
0
Visit site
Rev2010, that would be ok for when I'm not using the physical keyboard, or does it fix that too?

rushrl, I did an online chat and the rep said he would create an incident report, but it seems that he was aware that it was an issue already.
 

Rev2010

Well-known member
Oct 26, 2010
852
67
0
Visit site
Rev2010, that would be ok for when I'm not using the physical keyboard, or does it fix that too?

I tested on both, physical and virtual keyboard, and it doesn't happen on my phone with either. The 3rd party keyboard app will function with both the virtual and physical keyboards. One of the other reasons I switched to a 3rd party keyboard app is because the auto-correct didn't work with the physical keyboard with the built in.


Rev.
 
  • Like
Reactions: circustravis

black110

New member
Mar 8, 2011
1
0
0
Visit site
My Droid 2 does the same thing and I hate it! I can't find any setting to turn it off. If I try to type "I paid $30 for it." My Droid 2 will change it to "I paid$ 30 for it." I guess I'm going to try to find a new keyboard. This is the only problem I have with the original keyboard and it has become very annoying.
 

dwaynewilliams#WN

Well-known member
Feb 17, 2010
2,397
47
0
Visit site
My Droid 2 does the same thing and I hate it! I can't find any setting to turn it off. If I try to type "I paid $30 for it." My Droid 2 will change it to "I paid$ 30 for it." I guess I'm going to try to find a new keyboard. This is the only problem I have with the original keyboard and it has become very annoying.

Is this on the multi-touch keyboard? Because the swype keyboard and the physical keyboard doesn't do this.
 

justin1578

Well-known member
Nov 7, 2010
377
1
0
Visit site
I only use the physical keyboard and it happens %100 of the time. I've learned to hit the spacebar twice befor hitting alt or altlock.
 

dwaynewilliams#WN

Well-known member
Feb 17, 2010
2,397
47
0
Visit site
I only use the physical keyboard and it happens %100 of the time. I've learned to hit the spacebar twice befor hitting alt or altlock.

The multitouch keyboard is the culprit. If you enable the swype keyboard and use the physical keyboard it does not do that. I just tried it. I have swype enabled all the time. I don't get the word predictions but I am not getting the little bugs like the OP described. That's a weird little glitch.
 

dwaynewilliams#WN

Well-known member
Feb 17, 2010
2,397
47
0
Visit site
I have also noticed another glitch as now I have started playing around with this to see what the differences are. If you have swype enabled and want to use voice to text in a text field, it doesn't work. Only the voice search works when hitting the mic button. But if you have the mulittouch keyboard enabled, you can do voice to text.
 

circustravis

Well-known member
Jun 18, 2010
108
2
0
Visit site
Maybe this should be a new thread, but does anyone know if there's a way to get word suggestions with Swype enabled, but using the physical KB?
 

Rev2010

Well-known member
Oct 26, 2010
852
67
0
Visit site
Maybe this should be a new thread, but does anyone know if there's a way to get word suggestions with Swype enabled, but using the physical KB?

You can probably do this with a 3rd party keyboard app as you'd then be able to assign the virtual keyboard to Swype and the physical to the 3rd party app only.


Rev.
 

Latest posts

Trending Posts

Forum statistics

Threads
944,343
Messages
6,922,403
Members
3,159,506
Latest member
RVHauler