[Q] [HELP] Help needed with my Moto G stuck in Bootloop. USB Debugging not enabled.


New member
Feb 4, 2016
Visit site
Hello everyone

I own the Motorola Moto G ( 1st gen) xt1033 model. I had cm 13(latest release) flashed on it and my custom recovery is TWRP and it was working fine until today after using it for around 2 months.

So what happened today is that while running an application, my Moto G shut down randomly( I don't know the reason for that),and it got stuck in bootloop ( Everytime I start it, the cm logo will appear and then it sometimes even shows my lock screen but instantly becomes black after that and most of the time its stuck only on the cm logo). After this I thought of restoring it back to the original firmware, but this happened

I can get into fastboot mode but can't access the ADB as USB debugging mode was not enabled ( that's the main problem )

So following the procedures of a post on restoring moto g to stock firmware, everything worked well on the log of the fastboot (no errors) but after that when I reboot my phone, again the cm logo appears (Even when I flashed it to stock 5.0.2 Lollipop!) and I can even get to my old lock screen sometimes and then instantly it goes black. Even if I try flashing a custom image like stock or some other ROM , it gives no effect as again the cm logo would appear.

I think this has to do with the fact that USB debugging mode was not enabled on it.

Also, I can't enter my recovery. When I use the standard procedure to get into fastboot (power button + volume (-) ) and select recovery, the TWRP splash screen comes then the screen turns black and normal reboot takes place( stuck on the cm head). I tried flashing different recoveries using fastboot (also tried mfastboot) like CWM and even TWRP again but still that bugged TWRP recovery remains.

I can't get to recovery neither can I boot up my phone. I can flash recovery or image files(It shows no errors flashing things, but no effect takes place :/ )

Can someone please help me in finding the solution for this problem? Thanks in advance

Trending Posts

Forum statistics

Latest member