Restore samsung s7 to factory settings, stuck in a boot loop


AC Question

Hi guys, been trawling the forums for a solution to my problem but I havent had any luck. Pretty new to Android and much of the lingo is like another language to me so please be kind!!

I rooted my phone, and somewhere along the way after rooting it loads up the boot screen which displays "samsung" and just freezes and restarts each time failing to boot up. I can get to the download mode screen.

Now I made a backup so I'm not bothered about losing all of my data so I've tried to use odin to help but I'm getting errors. I've used previous versions of odin but I'm not 100% sure I'm using the correct ROM for my phone.

My phone is SM-G930F, I use the network three (H3G) and I live in the UK.

I'm getting this message...

set pit file
do not turn off target

Any help would be greatly appreciated thank you
Oct 17, 2014
Visit site
Hey there,

Did you manage fixing this?

I'm having a similar issue with one phone as well.

If you haven't fixed it, you can also try samsung smartswitch

on another phone S6 edge I had the same issue and used samsung smartswitch(official software from samsung) to reload the os and it worked perfectly, you just need to have the phones serial/model number and IMEI# to use smartswitch

search online there are lots of guides on how to reload the os with smartswitch, very easy to do.

And if you managed to fix it already another way, let me know maybe it will help us as well