[RoM] AOSP 4.0.3 - updated 02/11


Well-known member
Feb 27, 2010
Visit site






Built from source

What's working
-4G wimax

What's not working

This does not flash a radio.

How to flash
-First you must have unlocked bootloader and custom recovery installed.(if not refer to the sticky at the top of this section.)
-Download ROM.zip,Gapps,Face Unlock
-Copy all zips to your sdcard.
-Reboot custom recovery
-make a nadroid backup
-Wipe everything data/factory reset and cache-Yes,You HAVE to
-Flash ROM.zip
-Flash gapps(should be able to flash right after the ROM)
-Reboot to full system
-Reboot recovery-optional
-Flash Face Unlock-optional

If you have or use any apps to back up restore data/apps then it's a good idea to full wipe and start over to avoid any problems. Download all you stuff from the market again,we all hate doing it but makes for a much smoother experience


Thanks to
-Cory Streater
-Phil Nickinson
-all the developers that work for Google
-Team Hydro

By downloading the ROM you agree to the following

-You will read all of post 1,2,3
-You choose to flash this ROM,it's no ones fault but your own if it breaks
-You have read the whole first,second,third post and want to flash this ROM.
-You understand that this is all done for FUN don't expect/ask for eta on updates.(Their ready when their ready.)
-You will not take this work and go post it somewhere else,you can link to it if you like.
-You agree Dooderbutt is better then Okotte Nakama(The GSM build which can be found Here :p

v-6 has major changes and might require a full wipe,if flashed with just wiping cache/dalvik and issues(Force Closes) happen full wipe.Use the new Gapps zip provided
Downloads for NS4G



Face Unlock

-added full rotation/even on lockscreen
-added onscreen buttons(see post 3)
-removed wake on unplug
-fixed voicemail now dials your phone# instead of *86
-fixed a issue with idle
-added Reboot Mod
-more that i don't remember at this time
-added custom kernel (OC/Uv) if you want runs stock speeds by default
-added custom battery icon(Major props to jstntp) (See post 3 for removal)
-added custom clear all to notification area(Major props to jstntp)
-added custom wallpapers
-updated gapps
-major tweaks to system for better performance
-added a custom script in (system/etc/bln.sh) that can be adjusted instead of using a app.More details to come on how to edit this file.For those that want to check it out look at the file with a file explorer or adb. Save changes and reboot.
probably more that I'm forgetting
-Added custom wallpaper-Jon
-Calendar sync should now work(As long as you wiped)
-Market fix for paid apps-See Post#2 for work around
The market is acting this way because we are using a ICS footprint instead of a GB footprint.
(Also do not restore any backed up info,only sync with your google accounts.)
-maps should allow you to log in now
-Added superuser.apk and new binary to ROM package. Thanks ChainsDD
-Added Voodoo Sound
-Added Voodoo Color
-Added Busybox 1.19.3
-Added init.d scripting support
-All apk files zipaligned
-Launcher2.apk png optimized
-Custom wallpaper added to Launcher2.apk
-MMS fixed
-fixed calendar sync
-Gwallet now works
-Custom livewallpaper
-added livewallpapers
-edited build.prop to fix market issues
-whatever google changed
-added extra flashable tweaks
-Tweaks to hope Mms work outgoing
-first release of Dooderbutt built from AOSP

Widgets from my screenshot


Last edited:


Well-known member
Jan 18, 2011
Visit site
Re: [rom] aosp 4.0.3

How to purchase paid apps on the market:

If you would like to purchase a NEW app from the market, the first thing you need is to launch your Browser from either, Your Phone or your PC. I have done it both ways and its verified working ( ie. I bought a bunch of stuff I didnt need to JUST to make sure it works.)

Once you get on the market webpage ( www.market.android.com ) , you can now sign into google from the top right corner and then you will have the same options that you had in the market, and then some...

Once you purchase the app that you wanted it will send the download to your phone and automatically install. This is a work around, but a dang good one! Hope this helps all of you that are in need of buying some new years apps! Good luck and ENJOY DOODERBUTT!!!
Last edited:


Feb 6, 2011
Visit site
Re: [rom] aosp 4.0.3

*****You must upgrade to Dooderbutt v7 before flashing these mods. You will experience problems if you don't. :p*****

Wipe caches and flash in recovery:

v7 mods:
Onscreen controls:
dbutt-aosp-v7-onscreen-controls.zip -- Adds onscreen controls dbutt-aosp-v7-no-onscreen-controls.zip -- Reverts back to no onscreen controls dbutt-aosp-v7-no-lock-rotate.zip -- No onscreen controls as well as no lockscreen rotation. dbutt-aosp-v7-no-lock-rotate-yes-screen-controls.zip -- Adds onscreen controls but no lockscreen rotation. Launcher 5x4 grid:
dbutt-aosp-v7-Launcher2-5x4-mod.zip -- This mod changes the current Launcher workspace grid from a 4x4 to a 5x4 layout. (5 across - 4 down) dbutt-aosp-v7-Launcher2-stock.zip -- Stock 4x4 setup Rotate mods: (click image to see gallery) dbutt-aosp-v7-phone-contacts-rotate.zip -- Enables full rotation of the Dialer, Recent calls, and Contacts.

Misc. mods:
Transparent-powerwidget-4g.zip -- Transparent Power Widget and 4G Widget mod

[NOTE]Credits & Thanks

Paul627g for helping me with my recent apktool issues
My mentors and teammates -- Team Hydro[/NOTE]
Last edited:


Well-known member
Jan 17, 2011
Visit site
Finally got home too download! All set up now. So far so good. Followed beezy's instructions and flashed rom, booted, flashed gapps and su and booted again. Gallery took a couple more reboots to fully incorporate itself from SD....camera shortcut on home screen is tied to nothing...just remove and reload from app drawer if you want..... had to disable auto rotate, reboot and re enable auto rotate to get screen to rotate. Gmail fc's from titanium backup, gonna delete and dl from market to see if that fixes issue. Other than that no real problems so far. Quick and smooth. Thanks again beezy and co!

Edit--uninstalled Gmail and restored just app, no data, and alls good :)

Long days and pleasant nights............
Last edited:
  • Like
Reactions: beezy


Well-known member
Oct 6, 2010
Visit site
Re: [RoM] AOSP 4.0.3

So will glados or some other kernel work until you get the Voodoo, BLN, init.d, etc? I dare not test this out my self :cool:

GLaDOS 2.1 and 2.2 work just fine on breezy's kernel. Have gotten deep idle to work as well. I have also tried Matr1x 12.5, and this works just fine as well.

I have installed Voodoo separately, and this is working as well. Colors are rich with voodoo control.



May 16, 2011
Visit site
Re: [RoM] AOSP 4.0.3

Hey guys. Sorry for the noob question

What are Gapps.zip and su.zip for? I already have superuser priveleges, does that mean that I do not need to flash su.zip?


Well-known member
Dec 10, 2009
Visit site
Re: [RoM] AOSP 4.0.3

Hey guys. Sorry for the noob question

What are Gapps.zip and su.zip for? I already have superuser priveleges, does that mean that I do not need to flash su.zip?

Gapps are the stock Google applications, i/e gmail, talk, market ect. su.zip is the superuser app which would need to be flashed if you want to have superuser privilege .


May 16, 2011
Visit site
Re: [RoM] AOSP 4.0.3

Thank you very much. Again pardon the ignorance. This is my first time rooting and i want to get it right. I unlocked my bootloader and gave myself superuser priveledges. yesterday

I am assuming that I will still need to follow the instructions in this post to the letter and go ahead and flash su.zip as well.

Anyway i just dowloaded the java and the android sdk, I subsequently updated it. I am following the instructions in the sticky from: "http://www.androidcentral.com/unlock-bootloader-and-install-su-and-cwm-nexus-s-4g-forums"

I am on the step where is says to:

"go into the Settings menu, then choose Applications > Development > USB Debugging. After you've done that, plug your phone into your computer and let it try to install all the drivers. It'll mostly succeed, but something will be missing. This is where PdaNet helps us out."

I installed pdanet on my windows pc because I saw it as a prerequisite instructions. I believe that it already installed necessary samsung drivers. My issue is that when I plugged my phone in to "let it try to install all drivers" I did not see that occur.

Is that normal? Am i safe to proceed in getting adb? Any help and insight is much appreciated


Well-known member
Apr 2, 2010
Visit site
Re: [RoM] AOSP 4.0.3

Just jumping in, but go ahead an try adb, won't hurt anything if it doesn't work. You also need to go read those instructions carefully, there are some good stickies at the beginning.

The biggest mistake is in the sdk drivers. Platform tools must have adb as well as your recovery in the same folder. Check it, move it. Or if you are pointed at Tools, the same.

Also to open command prompt, its not the normal one on the computer, it opens from android. It entails a right click, just tried it and I can't remember.

I'm not adb proficient, so since you are new highlighting the two mistakes I cussed about for 2 days.


Well-known member
Oct 6, 2010
Visit site
Re: [RoM] AOSP 4.0.3

wait...just noticed something.

What's the difference between your dooderbutt ROM 4.0.3v1 and this ROM listed in this post?
  • Like
Reactions: gulrezm