• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

rooted Samsung Galaxy 4 Tablet mulfunctions after unrooting itself.


New member
Nov 28, 2013
I have previously rooted the tablet and installed a few apps. It worked perfectly for a few weeks, until I installed the Halo and X floating windows software. This software never really worked and now all of a sudden the tablet is malfunctioning: the desktop Home screen with all the apps has all but gone: badly shrunken, black background, some of the app icons are overlapped and cannot be clicked on. Actually I can't even see all of them. I rebooted several times, to no avail. .Strangely, though, there is a side bar popping in and out , with many apps.When I click on any of the icons, the apps do open( unlike before) as floating windows of reduced size, but they are really too small and the size cannot be adjusted. In brief, the tablet has become unusable. I managed to go to Root Checker, though: it tells me that I have lost root access. How so? I also got a message saying that there is an app called Knox (?) which seems to be in the way. What can I do? Is the device bricked? I hope not.

Thank you for your help