• Welcome to the all-new Android Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

S3 GT 19300 4.3 backup before cyanogenmod


New member
Jan 31, 2014
Hi, this is my first post here so please be kind.
This is my first time rooting the phone and installing custom rom. i wish to install cyanogenmod since im really tired of the stock rom crashing all the time. I recently received the 4.3 update, like a few weeks back, and ever since my phone has been having major issues. the dialer, contacts, messages, touchwiz etc keep crashing very frequently.
So i decided to root my phone and ever since the root my phone has not been having issues as much as before.
After rooting, i installed rom manager and using the recovery tool i created a back up.
1st attempt: i accidentally opted for creating a backup on sdcard0(phone's memory), which did not have enough free space i believe and it resulted in showing me an error in the middle of the process.
so i backed out and created a backup on sdcard1 (32gb), the backup was successfully created but then i made a mistake again. I was presented with a yes/no question "Rom may flash stock memory" and another question which i cant remember. I opted no for both and then started having a boot loop problem.

I managed to go back into recovery mode and while people had advised to factory reset the phone instead i decided to restore the data which i had recently backed up.
During the restore process i was prompted with an error, not sure why. it then asked me the yes/no questions again (Rom may flash stock memory...) but this time i chose 'Yes' as the options to both questions.

The phone rebooted and the boot loop issue was gone :). But now i got a notification 'not enough free space in sdcard0'.. i cleared up some space and moved my files but im confused if there are any backup files in the phones memory which were created during the first attempt at creating a backup (which later showed error). I did try looking for clockworkmod folder in my phone's memory but its not there. Although there is a backup folder in sdcard1 which was probably created during the 2nd attempt at backing up my device.

Q. Could it be that some files were created on my phones memory during my 1st backup attempt that later failed with an error. i had about 1gb free in my phone's memory before i tried to create a back up and now it only shows 350mb.
Q. Why was i presented with an error while i was trying to restore the backup to fix the bootloop. (back up which was created during the 2nd attempt).
would you suggest that i delete this backup and create a new one?
Q. How do i backup my phone before installing cyanogenmod so that i am able to restore all my app data, contacts, messages etc.. i checked out carbon helium and titanium but i cant figure how will i be able to restore all my data excluding the system files, which i believe will cause an issue if im running cyanogenmod.

I apologize for the lengthy post and also for any confusion the reader might have in understanding my issue. Like i said, its my first post here and i tried to be as clear as i possible could.

Explain it like im 5 (if its possible)