S3 I9300(International) got soft-brick..Need HELP. What should I do?


AC Question

S3 I9300(International) got soft-brick...Need HELP

My GT-I9300 international galaxy S3 gone brick itself, all of a sudden its stuck at the boot screen (white samsung ... text). I was using Cyanogen Rom 12 Unofficial Lollipop 5.1 for around 3 weeks (Everything Works Fine with few Lags and Reboots rarely in a day). I used various method's from noob to expert solution but didn't find success

Tried to reboot into recovery but no go, when i hold the buttons it just continues to reboot and reboot, only showing the white text.
Tried to reboot into download mode and that worked, i though fhew, i got a breath and not all is lost(Phone itself).
In Download mode,
It says :
Product name = (Blank)
Custom Binary Download = No
Current binary = Samsung Official
System Status = Custom

Tried to recover with kies, but it complains that it cannot install new firmware (after i downloaded the firmware, extraction, and all instruction followed).
Tried with odin (several original roms with my region and the one from kies) but with no luck, odin complains "There is no PIT partition.".
Tried to repartition with GT-I9300_mx_20120329.pit but then it does SET pit and hangs on "Get PIT for Mapping".
Tried One Click Method but failure is what resulted.
Didn't Tried JIG Method (will buy if nothing works).
Is there any chance to save my phone ? I'm getting really desperate here.
A Beer is sure to one that gets my problem solved
---Waiting for Good---


Retired Moderator
May 23, 2010
Visit site
Re: S3 I9300(International) got soft-brick...Need HELP

Try re-installing Odin, redownload the stock file (for your model S3), and try another USB port and see if that helps. If it doesn't, then it's probably bricked and may need to be replaced or sent to Samsung for a fix - since it's outside warranty they may not even cover it.