S9 disconnects if paired to two devices

jonwells`

New member
Aug 7, 2011
2
0
0
Visit site
I drive my Toyota with my S9 paired to my Pioneer head unit and a Garmin GPS. Every few minutes it disconnects from the Garmin and a "S9 is disconnected" message is displayed. After a few seconds it recovers. This continues to happen all the time I'm driving.

I have found that if I unpair from the Pioneer there is never a problem with the GPS.

Does anyone have a solution?
 

Hermes Hidayat

Well-known member
Feb 6, 2017
2,617
2
38
Visit site
I drive my Toyota with my S9 paired to my Pioneer head unit and a Garmin GPS. Every few minutes it disconnects from the Garmin and a "S9 is disconnected" message is displayed. After a few seconds it recovers. This continues to happen all the time I'm driving.

I have found that if I unpair from the Pioneer there is never a problem with the GPS.

Does anyone have a solution?

Okay so the Garmin is just a GPS. But on the Pioneer you are using it as a music player or just for calls?

Sorry for asking but why connect a phone to a GPS?
 

Hermes Hidayat

Well-known member
Feb 6, 2017
2,617
2
38
Visit site
With the Pioneer it is just for calls. For the GPS it enables current traffic conditions and weather.

erm,im not sure if it will fix it but you can try to go to bluetooth settings.go to Garmin and disable all the available options(call audio,media audio and contacts access.)

but correct me if im wrong but dual audio is for lets say using 2 speakers to listen to music or make phone calls.im sorry i couldnt help much.