Samsung Galaxy Note 4 BOOTLOOP stock ROM (dm-verity verification failed).

Kenesu B

New member
May 30, 2020
Visit site
I’ve tried looking for solutions online, but to no avail I can’t seem to fix by myself I have recently installed LineageOS 16 , been using it for months until recently it started to slow down, and die down what i mean is the booting process takes time and after booting there is some random crashes and it reboots , I was able to solve the problem using TWRP by wiping out the cache and resetting back to factory settings, but it was taking so long to boot after and then I decided to flash it once again, started from scratch and it worked for some time until it crashed once again leaving me to unfixable bootloop, it stays on LineageOS logo, then screen dims and then just bootloops, so i decided to flash the STOCK ROM using odin which apparently worked It booted and the process was painful because every boot im doing it got slower and slower until it would be stuck at Samsung Logo and then reboots once again, so I reflashed it once again and when it booted, I was bombarded by system apps not reponsing properly, icon like ‘System UI has stopped’ and then most of the In-built app would do the same and it crashed this time, this time when it booted it is stuck to samsung logo, so i tried wiping the cache and formatting data on stock recovery and it is still stuck on boot-loop, if lucky it goes to samsung logo and just literally in that state forever, i left it for hours and it is still the same. and then when i tried booting to stock rom there was a message below that says (dm-verity verification failed), I googled it and it is a cause for tampering system files and I just couldn’t get to work it out and find a proper solution. I hope you all can help me out. Every-time i try to flash the stock rom the message is , (Installing system updates, error, goes to recovery then it has the problem below) If anyone has encountered the same problem, or has a solution I would appreciate it. Thank you.


Super Moderator
Feb 6, 2017
Visit site
Yes , It is stuck in the bootloop , now encountered the problem ‘Kernel is not seandroid enforcing’

Samsung Galaxy Note 4
SM-N910c Treltexx
Try re download the firmware again and flash , even check samfirm tool or frija tool for firmware, putting stock firmware should of fix your issue unless whatever you done modifying damage something .

Trending Posts

Forum statistics

Latest member