samsung galaxy s3 samsung logo flashing keeps restarting

Angel Angel1

New member
Mar 10, 2014
1
0
0
Visit site
Hi,

Two days ago I got the official update of jelly bean 4.3 to my Samsung galaxy s3.Last night phone was dropped with in small height. Today morning I switched on the phone its worked fine. But at the evening suddenly my phone was restarted and Samsung Logo Splash Screen (Samsung galaxy S3 GT-I9300T) and Keeps rebooting. So I remove the battery and insert it after a few second. After that the phone worked fine and again the same problem happened.

if I remove the battery, phone switch off. And if I insert the battery again, phone switch on itself (without press power button) and keep restarting.
I try to open the (Home + Volume Up+ power ON) button option. But is not working. If I plug the phone to charge, gray battery shows and again restarting to charge?. (I mean, phone won?t stay in a stage).
If i try (HOme + voulme down + power On) option, phone shows the download mode for 5 seconds and restart again.
So can you please let me know it?s a software problem or hardware problem?
If it?s a software how fix it ? ( I tried the emergency firmware recovery through kies, but kies couldn?t fine my phone).

My phone current status video below
https://www.dropbox.com/s/xvq6bd93qjmdt6o/20131012_235047.mp4

Note : this video i download from youtube, bcoz i wanted to show u the current situaltion. ( But my phone in critical rather than wht mention in video)

Thank You.
 

GSDer

Well-known member
Jan 30, 2011
8,471
15
0
Visit site
if I insert the battery again, phone switch on itself (without press power button) and keep restarting
If the phone boots up when you insert the battery, it sounds like you damaged the Power switch when you dropped it (or the plastic piece that you press on has gotten jammed against the switch, causing it to always be depressed).

You could try gently prying the little plastic piece out, or see if you can find someone comfortable with this sort of thing.

At worst there's always something like http://mobiletechvideos.mybigcommerce.com/samsung-galaxy-s-iii-power-button-repair/