Samsung Galaxy S7 - Error searching for networks, very intermittent registering

EladDinur

New member
Aug 14, 2018
1
0
0
Visit site
I have a Samsung Galaxy S7, bought in Canada, locked to Rogers.
Phone was unlocked through Rogers.
model is SM-G930W8.
I moved to Israel, and bought a new SIM with an Israeli Carrier (we4g).
The phone does not register on network. The following details are relevant:
- Frequencies should comply, I checked it on the web.
- When trying to search for networks, I get error searching for networks.
- Upon initial insert of the sim I get a signal, I get a configuration message and a text telling me to install it, than signal is lost
- Looking at sim card status I see:
- Network - changes from Cellcom IL to unknown every second.
- Mobile Network type is unknown
- Roaming - not roaming
- I have tried the sim in another phone, it works.
- I have tried other sim, also from we4g, and it worked and I could make a phone call. I tried another SIM form Hot Mobile, I could make a call. After restart - phone lost signal, exactly like with my new SIM
- when SIM is not inserted I can make an emergency phone call.

IEMI number is not Null.

Does anyone know what is going on here?
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
28
0
Visit site
Find out from Cellcom whether they use 2G or 3G to connect to the network. If they use 3G (which is becoming more common these days), the phone doesn't do 1800 3G, which would be the problem. (It may be allowing you to connect on 2G, then trying to switch you to 3G, which won't work, so you connect, then disconnect.)

(The W8 variant - Canada - isn't the F variant - Global - although the global variant wouldn't work either if that's the situation.)
 

Members online

Forum statistics

Threads
945,126
Messages
6,924,298
Members
3,159,673
Latest member
netabb