sAMSUNG J3 NO Longer recognised by my computer but USB ports and cable working

  • Thread starter Android Central Question
  • Start date

Android Central Question

Until this time when I tried to download my photos from phone to computer it has worked immediately The computer recognised the phone and I downloaded the files. Now the USB port and cable is working, the phone just manically beeps but computer dows not recognise the phone. I have tried all that everyone said but when I go onto the pull down menu of Storage I do not have a "More" icon. I cannot find anything on the phone related to USB and I never had to do this in the first place. What is going on please? I have to dismount the Memory Card and insert into Hub of computer each time I want to download photos.

B. Diddy

Senior Ambassador
Mar 9, 2012
Visit site
Welcome to Android Central! Have you already tried different USB cables? How do you know for sure the phone's USB port and the cable are working properly? Keep in mind that it's possible for a cable to become faulty and only charge (without being able to transfer data).

Please register on this forum, which will allow you to engage in discussion more easily, as well as post images.