Samsung S3 Mini: How do I fix being stuck on the logo and get the phone on without losing data?


AC Question

Hi all, my Samsung has recently started to restart itself quite often and one day it was stuck on the flashing Samsung logo. I just took out the battery and put it back in again and it worked fine. This happened a few more times but I just took the battery out each time and it would work again.
Last night I was just about to hook my phone up to my computer to transfer pictures and other files when the phone restarted and got stuck on the logo. I took the battery out as usual and put it back in but it didn't work. I tried it a few times and then left it for a half hour and still it wouldn't work. The proper battery thing comes up when I have the phone plugged in to charge. I went around the web and found how to get the recovery menu up and chose the clear cache partition, hoping it would work to get the phone on again. A screen with a loading bar and the word "erasing" came up for about a second and then cut to the little android man saying error and the phone restarted itself and got stuck on the logo again.
So, I tried it a few more times and it did the same thing. I then went with the "reboot now" option which was essentially just restarting it? So that didn't work either.
I have a micro SD card in the phone and some web pages I've read said to remove that and the SIM card as well as the battery and to leave them out for a while and then just put the battery in and try to turn the phone on and then put the cards in later etc. but I might mess up the files on the micro SD if I don't unmount it which I can't do because the phone won't come on.
I really have no idea what to do now because I don't want to lose anything on the phone's memory or the card by doing the factory reset or anything else, and since the clear cache thing seemingly didn't work I'm not sure what will. Someone please help!