Samsung S4 won't connect to 5ghz wifi

OPZoro

Member
Jan 29, 2017
7
0
0
Visit site
At first when I set up my router (TP-Link AC1200) my phone can connect to the 5ghz network but now it won't. I could get the signal and could tap on it to enter the password, but when I press connect it only showed as "Saved, Secured" but would not connect to it.
My friend's tablet E and IPhone 7 can connect to my 5ghz network and maxed out the speed limit. Even my laptop that support ac can connect to it too so it's just my S4's problem.
I've tried various solutions I found on the net but none of them worked.

Android version:4.4.2
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,962
3,982
113
Visit site
Welcome to Android Central! Have you already tried forgetting the network, then connecting again?
 

OPZoro

Member
Jan 29, 2017
7
0
0
Visit site
I can connect to my 2.4ghz but just not the 5ghz. Every time I try to connect to it the phone would just keep scanning, it's not even attempting to connect to my 5ghz. The router is right to the phone, the 5ghz network sometimes is on the bottom of the available networks then it would jump to the top after the phone finish scanning.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,962
3,982
113
Visit site
Have you already tried rebooting the router, by unplugging its power for 10 seconds and then plugging back in again?
 

OPZoro

Member
Jan 29, 2017
7
0
0
Visit site
Anything here helpful? http://forums.androidcentral.com/sp...nt-wifi-issues-802-11ac-5ghz-connections.html. Sounds like for at least some folks, it's a hardware issue.

Also, do the 2.4 GHz and 5 GHz networks have the same SSID? If so, try changing them to be different from each other.

The 5ghz ssid is added the "_5G" at the end to differentiate from the 2.4 ghz. I used wifi analyzer and discovered that my 5ghz is not showing, but it would show up in the list of available networks after the device finished scanning.
And I don't know if this has anything to do with it, when I was able to connect to it for the first was when I set up my router for the first time. But I have had disabled the ssid and enabled it again. That's when my phone can't connect to it anymore.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,962
3,982
113
Visit site
Have you been able to try connecting your phone to other routers that have a 5 GHz band, to see if the problem is with your router or with the phone?

Also, this is a longshot, but make sure the router's firmware is up to date.
 

OPZoro

Member
Jan 29, 2017
7
0
0
Visit site
Have you been able to try connecting your phone to other routers that have a 5 GHz band, to see if the problem is with your router or with the phone?

Also, this is a longshot, but make sure the router's firmware is up to date.

I tried to connect another 5ghz network, the result is the same, couldn't connect to one. So the problem is just the phone.
The firmware of the router is up to date.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
164,962
3,982
113
Visit site
Another longshot -- go to Settings>Wifi, tap Menu>Advanced, and turn off Smart Network Switch (if it's there).
 

Trending Posts

Forum statistics

Threads
941,436
Messages
6,908,829
Members
3,157,927
Latest member
zigzagchamber