Samsung S6 Edge 128gb - USB Device not recognised and Fast Charge Not Working

vjm142

New member
Jan 10, 2017
3
0
0
Visit site
Good afternoon!

So I've had the S6 edge for a little while (since October 2015) and I had an issue suddenly come up a few months ago. I couldn't find a solution at the time, and Samsung were less than helpful when I went to them.

Basically I noticed my Fast Charge stopped working one day so had a look at forums and came to the conclusion that my cable might be the problem. So I ordered a new cable and adaptor (just in case). They arrived, tried the cable... tried the adaptor etc and all to no avail!

I decided to back up the phone and try to wipe the software... however when I went to plug it into my computer it came up with the old USB Device Not Recognised error. Read up that I had to update drivers etc, so did that, but it still kept coming up with the same error!

Hardware diagnostics have been carried out, software has been wiped and re-installed etc and still no solution!

Does any one here have any ideas or tests I can try out?

Thanks!

VJ
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,105
5,497
113
Visit site
Welcome to Android Central! It could be an issue with the phone's microUSB port. First, make sure it's completely clean -- use a can of compressed air to blow it out. If it's clean and the problem persists, the port might have to be replaced.
 

vjm142

New member
Jan 10, 2017
3
0
0
Visit site
Thanks BDiddy!

I did try that and had it replaced... but still to no avail!

Is it possibly a fault on the motherboard?

Thanks

VJ
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
166,105
5,497
113
Visit site
In that case, it's probably a hardware problem. It could be the microUSB port itself, or something on the motherboard. You'd have to bring it to a repair shop (or contact Samsung if it's still under warranty). Sorry!
 

Trending Posts

Forum statistics

Threads
945,652
Messages
6,926,464
Members
3,159,930
Latest member
GJAZZ