Sd card: Not able to give write permissions to ES File Explorer, etc.

cward0625

Well-known member
Nov 7, 2009
47
0
6
Visit site
I have a 128 gb Samsung pro + micro sd card. It is formatted as exFAT and my phone has encrypted it due to a work requirement. If I try to write a file to or delete a file in it from ES File Explorer or any other app, I get asked to provide write permission. However when I get the screen to select the sd card it is empty and the 3 dots in the top right when click just have an option for 'Hide SD card' which does nothing when tapped.

What do I need to do so that the phone can write to the sd card using apps?

Googled and not found anything specific to tgis issue, seems like others see the sd card to give permission.

Screenshot_20160618-074842.jpgScreenshot_20160618-074850.jpg
 
Last edited:

dpham00

Moderator Team VP
Moderator
Apr 23, 2011
30,108
200
63
Visit site
Unfortunately third party file browsers can't write to the sd card, at least not the free that I tried. You can use the stock my files app to write to the sd card.
 

Bag of Leaves

Well-known member
Apr 23, 2016
226
0
0
Visit site
Unfortunately third party file browsers can't write to the sd card, at least not the free that I tried. You can use the stock my files app to write to the sd card.

I use ES File Explorer just fine with my SD card. Mine isn't encrypted, so maybe you meant they can't write to only encrypted cards?

OP, did you try seeing if you need to give the app permissions under the app's info. in Settings? I don't know what else to suggest, sorry!
 

LePopNoisette

New member
Jul 17, 2016
1
0
0
Visit site
I get this message, too. I find that 'Select SD card ' appears across the bottom of the screen in a blue strip, but before I go hunting around for the card or going to 'Recent'. I post this because it used to frustrate me until I realised that this would show up. It is still annoying, though, because I can write to it without any prompts; it just seems to be deleting that brings this up.
 

VeganButEatMyMeat

New member
Apr 5, 2017
2
0
0
Visit site
I had the same problem and the issue was with "Package Disabler". If you choose to disable all bloatware then it denies you access to the SD card too. Just re-enable all disabled packages in Package Disabler and this will work.
 

SirMW

New member
Feb 6, 2019
1
0
0
Visit site
THANKS! I figured out my problem with Videoder not being able to write to my added micro SD card like it used to. I had disabled "Device Helper" because I had no idea what it was. So if you have this problem, try reenabling apps. :)
 

Trending Posts

Forum statistics

Threads
944,595
Messages
6,923,462
Members
3,159,633
Latest member
PerHapZ