Second account contacts showing in contacts

Mskitty0606

New member
Jan 23, 2017
4
0
0
Visit site
This is my first post so go easy on me! I'll try and explain best I can. I've tried searching the forums but can't find anyone reporting a similar problem.

I have a Samsung S7. I added my husbands account to my phone so I can see his calendar. I don't want or need to see anything else of his so I have disabled syncing on everything else .

The problem I've got is that in my contacts and on WhatsApp his contacts are taking over. By that I mean if we both have the same person in our contacts then it is the name he has given them that shows. So my mum is coming up as Sue instead of Mum, and his mum comes up as Mum instead of Jan. It's driving me mad!

Any ideas how I can stop this happening? If I delete his account from my phone will it revert back to the names i have given the contacts and if I do this is there another way he can share his Google calendar with me?

Thanks in advance.
 

SpookDroid

Ambassador
Jul 14, 2011
19,323
588
113
Visit site
If you go to your Google Contacts online (contacts.google.com), do you see the change there or do you see yours? If the latter, then the sync has overwritten the contacts, but fear not, Google Contacts does have a way to revert to whatever state your contacts were up to 30 days prior.

If the contacts online aren't showing the change, then go to your Contacts app, tap More, go to Settings, and select Contacts to Display. Is your husband's account there? Try hiding it either by selecting only yours or on the Customized List.
 

Mskitty0606

New member
Jan 23, 2017
4
0
0
Visit site
Thanks for taking the time to reply.

I've done as suggested and checked my Google contacts online and they are all still there and as they should be but I selected restore anyway just to be on the safe side. I've also checked the contact settings and my account is the only one selected.

My contacts are now showing the correct names but when I go to send a message I'll search for Mum and select her number but then as soon as I select it, it changes to Sue Mobile so the problem is still there.
 

SpookDroid

Ambassador
Jul 14, 2011
19,323
588
113
Visit site
Have you rebooted your phone? If that doesn't help I'd go to your Application Manager, find Contacts Storage (you might have to select Show System Apps for that) and first try clearing its cache. If that doesn't work, try clearing its data (just remember to make sure that ALL your contacts are, indeed, in your Google Account) and reboot; your phone should re-sync your contacts after that so you might want to connect to WiFi if you're on a metered mobile data plan.
 

Mskitty0606

New member
Jan 23, 2017
4
0
0
Visit site
Think I've sorted it. I had to remove my husbands account and add it back in again, disabling the sync straight away on everything but calendar.
 

Forum statistics

Threads
943,793
Messages
6,920,086
Members
3,159,232
Latest member
goodweather2024