Send a '1' to phone to accept Google Voice call?

RedRamage

Member
May 18, 2012
24
1
0
Visit site
So I screen my calls with Google Voice because I have it ring my house number during non-work hours. If I'm not at home I want my wife to be able to hangup so she doesn't take a call about server or hardware issues from my company.

I would like to map one of my buttons in such a way that it send a '1' dtmf tone to the phone when I'm in a call so that I can accept a Google Voice call on my cell phone without having to whip it out and pull up the keypad, and then press the button.

On my old WinMo phone I used AE buttons to set it so that when I long pressed on the volume up button, it would initiate VJKeyPress to send the tone for 1. This made it very easy to accept a call when I was driving with my BT head set. I'd answer the call, then hear the prompt, I could find the volume button by feel without pulling my phone out of the holster, and hold down the button to press '1'. I could do the whole job without taking my eyes off the road with only one hand.

And ideas of how to get this setup working in Android?
 

Ntchwaidumela

Well-known member
Feb 22, 2011
1,979
28
0
Visit site
I hope someone has a work-through for this, as it annoys the hell out of me. I don't know how it came about, since it's only occurred in the past two months. When I'm driving, or otherwise using my BlueAnt device, it tells me who's calling and allows me to accept or reject the call. When just carrying it, I can see on the screen who's calling (or recognize the individual ring tone). I DON'T WANT TO DIAL 1 TO ACCEPT CALLS!!! And if it takes a few seconds longer to dial the 1, it rejects the call.

The folks at Sprint don't know what's causing this, so had no answer to how to shut it off. Can anyone out there help with this? Believe me, it would be very much appreciated.
 

Masema

Member
May 27, 2011
12
0
0
Visit site
I hope someone has a work-through for this, as it annoys the hell out of me. I don't know how it came about, since it's only occurred in the past two months. When I'm driving, or otherwise using my BlueAnt device, it tells me who's calling and allows me to accept or reject the call. When just carrying it, I can see on the screen who's calling (or recognize the individual ring tone). I DON'T WANT TO DIAL 1 TO ACCEPT CALLS!!! And if it takes a few seconds longer to dial the 1, it rejects the call.

The folks at Sprint don't know what's causing this, so had no answer to how to shut it off. Can anyone out there help with this? Believe me, it would be very much appreciated.

Well your issue is different from the OP's. It sounds like you just need to log in to the Google Voice web interface and disable call presentation.

@OP, sorry, I don't know a way to do that. I'd probably just suggest setting GV to not ring your home phone. If you're home when you get a call, I think you could still transfer by pressing *

(Maybe someone else will have a better suggestion though.)
 

Ntchwaidumela

Well-known member
Feb 22, 2011
1,979
28
0
Visit site
So I screen my calls with Google Voice because I have it ring my house number during non-work hours. If I'm not at home I want my wife to be able to hangup so she doesn't take a call about server or hardware issues from my company.

I would like to map one of my buttons in such a way that it send a '1' dtmf tone to the phone when I'm in a call so that I can accept a Google Voice call on my cell phone without having to whip it out and pull up the keypad, and then press the button.

On my old WinMo phone I used AE buttons to set it so that when I long pressed on the volume up button, it would initiate VJKeyPress to send the tone for 1. This made it very easy to accept a call when I was driving with my BT head set. I'd answer the call, then hear the prompt, I could find the volume button by feel without pulling my phone out of the holster, and hold down the button to press '1'. I could do the whole job without taking my eyes off the road with only one hand.

And ideas of how to get this setup working in Android?

Found something. It's part of Google Voice security. In your computer, open Google Voice. Go to Call Screening and turn it off, then save the settings. That should do it.

Later: IT WORKED!
 
Last edited:

RedRamage

Member
May 18, 2012
24
1
0
Visit site
@OP, sorry, I don't know a way to do that. I'd probably just suggest setting GV to not ring your home phone. If you're home when you get a call, I think you could still transfer by pressing *

(Maybe someone else will have a better suggestion though.)

Unfortunately, I fear you might be right. I was hoping to avoid this as I don't want to have to keep my cellphone next to me all the time. If I'm down stairs or upstairs and my phone in on the main floor it's nice to not have to race to get it if it starts ringing...
 

Forum statistics

Threads
942,829
Messages
6,916,096
Members
3,158,673
Latest member
cincin99