Sending text message to short codes

gomezz

Well-known member
May 8, 2021
274
60
28
Visit site
Been having a problem recently sending or replying to text messages with a short code. A bit of delving today and I have come across what appear to be a new setting in Samsung settings to control messaging short codes with it by default being to set to Block as it cannot determine if the short code is to a premium rate service or not. I have now set it to Ask (can be set to Allow) and can now set Allow or Block by number. I was actually trying to text my service provider about upgrading my package so a shame the Samsung update was not able to recognise that on installation.

Apologies if this is already a well known thing but it was news to me.
 

RickMG

Well-known member
Apr 19, 2010
135
5
18
Visit site
Been having a problem recently sending or replying to text messages with a short code. A bit of delving today and I have come across what appear to be a new setting in Samsung settings to control messaging short codes with it by default being to set to Block as it cannot determine if the short code is to a premium rate service or not. I have now set it to Ask (can be set to Allow) and can now set Allow or Block by number. I was actually trying to text my service provider about upgrading my package so a shame the Samsung update was not able to recognise that on installation.

Apologies if this is already a well known thing but it was news to me.
Thank you for the tip as I'm having problems receiving short code messages from my cell phone provider. Problem is I don't either see or understand where you found the fix. Anyway you could walk us thru what you did. I search short codes and nothing comes up. I'm on a Galaxy S20+ with all the current upgrades. Thanks again.
 

gomezz

Well-known member
May 8, 2021
274
60
28
Visit site
Discovered yesterday that this option does not appear to be available on all builds of the software as it was not on my friend's S20FE which he got as the same time as I got mine but with a different service provider. A bit curious as he is on O2 in the UK and I am on Tesco in the UK which piggybacks on the O2 network and systems. Does anyone have a clue as to why O2 choose not to include this option?

To be precise the option itself is on his phone but there does not appear to be any way of adding the Messages app to it.
 

GizmoEV

Member
Sep 26, 2016
21
1
3
Visit site
I had the same issue of not getting security messages for 2FA from multiple sources. I finally called AT&T support and they said that a setting on my phone numbers was set to block those messages. They changed the setting and now I can use 2FA SMS again.
 
  • Like
Reactions: Laura Knotek

Laura Knotek

Moderator Captain
Moderator
Jan 8, 2011
12,089
4,820
113
Visit site
Discovered yesterday that this option does not appear to be available on all builds of the software as it was not on my friend's S20FE which he got as the same time as I got mine but with a different service provider. A bit curious as he is on O2 in the UK and I am on Tesco in the UK which piggybacks on the O2 network and systems. Does anyone have a clue as to why O2 choose not to include this option?

To be precise the option itself is on his phone but there does not appear to be any way of adding the Messages app to it.
Is your friend able to get this enabled if he contacts O²?
 

gomezz

Well-known member
May 8, 2021
274
60
28
Visit site
No idea. I don't think he is bothered as he has yet to have a situation where this is a problem for him.
 

Trending Posts

Forum statistics

Threads
946,028
Messages
6,925,992
Members
3,160,051
Latest member
AdrianBaw