Sent Messages Missing

wymang

Member
Dec 1, 2014
9
0
0
Visit site
Hello. I just upgraded to the S9 from the S7 Edge. Everything seemed to transfer over fine except my sent messages. All messages from the receivers are there. I used the backup from the Samsung Cloud and also the Smart Switch app and neither of them are transferring over the sent messages. I even tried a 3rd party app called This is very frustrating.

Am I missing something or is there a setting I need to enable?

Regards,
Wy
 

ABOSWORTH007

Well-known member
Oct 8, 2013
1,442
14
38
Visit site
Hello. I just upgraded to the S9 from the S7 Edge. Everything seemed to transfer over fine except my sent messages. All messages from the receivers are there. I used the backup from the Samsung Cloud and also the Smart Switch app and neither of them are transferring over the sent messages. I even tried a 3rd party app called This is very frustrating.

Am I missing something or is there a setting I need to enable?

Regards,
Wy
Are you using the stock messaging app? This is common when using a third party messaging app. It will show all received but not the sent messages. If you're using stock, I don't see why it wouldn't be showing them though. I want to say when I went from my S8+ to my S9+ that all messages, including sent, transferred over. I actually ended up just deleting all old messages a couple weeks ago. Is there something you really need to have? I'd say just start fresh on the new phone. It should be showing them though. Not sure why it wouldn't.
 

wymang

Member
Dec 1, 2014
9
0
0
Visit site
Are you using the stock messaging app? This is common when using a third party messaging app. It will show all received but not the sent messages. If you're using stock, I don't see why it wouldn't be showing them though. I want to say when I went from my S8+ to my S9+ that all messages, including sent, transferred over. I actually ended up just deleting all old messages a couple weeks ago. Is there something you really need to have? I'd say just start fresh on the new phone. It should be showing them though. Not sure why it wouldn't.

Hi Abosworth -

Thanks for replying. Yes it's the stock app. After some digging and research, this seems to a common problem when Advanced Messaging is turned on. I did a backup/restore test and it seemed to work. The sent messages were there after I disabled it.

I guess I can start fresh. I need to delete A LOT of the old messages anyway. Not sure why I even keep them. I'll keep the pics though.

How are you liking your S9? Anything cool and exciting about it?
 

ABOSWORTH007

Well-known member
Oct 8, 2013
1,442
14
38
Visit site
Ah yes, advanced messaging.. I've had some issues with advanced messaging myself. I actually had to have AT&T revoke and then reinstate my MMS privileges to get it to work consistently. I was constantly not getting MMS. Also, I use Nova Launcher and the badge unread counts don't work properly whenever someone sends me an advanced message. If I toggle it off, it works fine. I do like receiving the higher quality MMS so I leave it on and deal with the badge issue.

Anyway, glad you got it sorted. I do really like this phone! I've had a lot of Samsung phones. S4, S5, S6, S7 Edge, S8+ and now S9+. This is definitely the best one I've had. I have a few gripes but I do feel that the Galaxy line keeps improving year after year.
 

Trending Posts

Forum statistics

Threads
942,875
Messages
6,916,346
Members
3,158,716
Latest member
kora_soge