Shaw Go SSL certificate untrusted after S7 Oreo update


New member
Jun 26, 2018
Visit site
I've tried everything I can think of, uninstalled and reinstalled Firefox, I tried using both chrome and the default internet app, cleared caches, made sure my date and time was set to automatic, and restarted my phone many times.
I've tried talking to Samsung but they insisted it's a problem with the internet provider, but my old S4 had been using the same connections at the same time without an issue.
Shaw has been much more willing to help but have been unable to find a solution, only coming to the same conclusion that it's my phone that's having problems.
The geek squad at best buy didn't have any further suggestions other than my final option and last resort, factory resetting my phone, which I'd really like to avoid if possible.


  • Screenshot_20180622-193730_CaptivePortalLogin.jpg
    127.5 KB · Views: 2
  • Screenshot_20180625-120221_Chrome.jpg
    134.2 KB · Views: 3
  • Screenshot_20180625-114941_Firefox.jpg
    244 KB · Views: 2
Last edited: