SIPDroid on Droid

cward0625

Well-known member
Nov 7, 2009
46
0
0
Visit site
I have tried setting this up on my new Motorola Droid but cannot get it to work.

I am looking for a solution where I have no coverage, could be in another country or whatever, have wifi, and want to make a call over VOIP.

I heard I could do this via VOIP and Gizmo5. Is there a better option.

I setup a Gizmo5 account, did not buy any minutes, not sure if thats necessary, its $10 a go so didnt want to just buy it if not needed....

I downloaded SipDroid from Android Market.

In SipDroid I set my username (i tried both the Gizmo phone number i got and my userid), password using my Gizmo5 info. I then put for the server:
proxy01.sipphone.com.

The dot in the top right corner of the phone is yellow, and then goes to red. I am unable to get a green light on it.

Any ideas?
 

cward0625

Well-known member
Nov 7, 2009
46
0
0
Visit site
i have google voice, but it appears to just use the phone to dial to a google voice #. I can't figure out how to turn off the verizon network connection to test this. I am used to blackberry where it was much easier to manage your connections. I tried network and connection settings, but nothing about the network except data roaming, etc.
 

adam8ch

Member
Nov 8, 2009
8
1
0
Visit site
recently discovered that the Google Voice doesn't provide any voip services. Sipdroid + gizmo5 does work. However you have to make the calls from the gvoice browser page, so that Gizmo5 interprets the calls as incoming rather than outgoing(which are not free).
 

Fschmid

New member
Nov 11, 2009
1
0
0
Visit site
Sipdroid and Gizmo now cooperate on Verizon Droid

The latest version of Sipdroid (1.1.8 beta) works beautifully with Gizmo now.

Outstanding work, Sipdroid developers :)

F.
 

cward0625

Well-known member
Nov 7, 2009
46
0
0
Visit site
Is there a way to turn off SIP Droid, it just starts itself. My droid does not last a whole day from 8am to 10pm like my old storm...i have advanced task killer, but that just kills tasks when i tell it to if i am not mistaken. I would like to have an option to have it not autostart. It seems to turn on based on the setting for how many signal bars you have. Just trying to find ways to make my battery last longer.
 

ircactus

Well-known member
Oct 8, 2009
77
0
0
Visit site
SipDroid &

Been playing with this app for the past few days. Without registering for any other accounts I've had successful calls using the following systems. (Not VoIP providers but rather sip servers and pbx's) Inbound and out on wifi only. Have not really tested 3g as my office sits in one of those non existent dead zone :D.
Might try tomorrow.

Vertical Televantage 8.x
SipReality TotallySip
Callbutler 1.9.16
 

SilverLight98

Well-known member
Nov 8, 2009
92
2
0
Visit site
To turn off the cell antenna but keep wifi on go to settings, wireless and networks, turn on airplane mode (turns off all antennas) then turn the wifi option on. Your cell antenna should be off while the wifi stays on
 

cward0625

Well-known member
Nov 7, 2009
46
0
0
Visit site
Been playing with this app for the past few days. Without registering for any other accounts I've had successful calls using the following systems. (Not VoIP providers but rather sip servers and pbx's) Inbound and out on wifi only. Have not really tested 3g as my office sits in one of those non existent dead zone :D.
Might try tomorrow.

Vertical Televantage 8.x
SipReality TotallySip
Callbutler 1.9.16

Can you explain how you use these for VOIP with the droid? I could only find info on callbutler, and that looks like something i setup on my pc?
 

ircactus

Well-known member
Oct 8, 2009
77
0
0
Visit site
Can you explain how you use these for VOIP with the droid? I could only find info on callbutler, and that looks like something i setup on my pc?

Exactly true. Callbutler is a free PBX for your office etc. All the systems I mentioned at some point require a sip trunk or for that matter an analog to sip converter (ie spa 3102) to get out to the pstn.

The reason for my testing was to ensure inter op in an office environment.

Most providers that allow you to bring your own device should work assuming you're setup up correctly. However I'd be more than happy to put a limited production Sip proxy online for testing. PM and I'll hook you into it.
 

MountainX

Member
Nov 29, 2009
10
0
0
Visit site
I have tried setting this up on my new Motorola Droid but cannot get it to work.

I am looking for a solution where I have no coverage, could be in another country or whatever, have wifi, and want to make a call over VOIP.

I heard I could do this via VOIP and Gizmo5. Is there a better option.

I setup a Gizmo5 account, did not buy any minutes, not sure if thats necessary, its $10 a go so didnt want to just buy it if not needed....

I downloaded SipDroid from Android Market.

In SipDroid I set my username (i tried both the Gizmo phone number i got and my userid), password using my Gizmo5 info. I then put for the server:
proxy01.sipphone.com.

The dot in the top right corner of the phone is yellow, and then goes to red. I am unable to get a green light on it.

Any ideas?

I just played around with this and I have it mostly working. I used SipDroid 1.1.8 beta with Gizmo5 on my Motorola Droid. I put it in airplane mode (cellular/3g modem off), then turned on WiFi and I can make outbound VoIP calls.

The only problem I'm having is that I'm not getting incoming calls. I use Google Voice with Gizmo for incoming calls. Normally, it works great. I've been using it for a while and it works on my Nokia N810. But for some reason it isn't working yet on the Droid. But I suspect it will work once I figure out the problem...

Anyone else using SipDroid, Gizmo and Google Voice on the Droid with WiFi only?

BTW, this is totally FREE if you have a Gizmo account with outbound credit. Just use Google Voice and it doesn't eat up any of your calling credit, so it is free. (And now that Google bought Gizmo, you have to have an existing Gizmo account - new accounts are not allowed at this time.)
 

MountainX

Member
Nov 29, 2009
10
0
0
Visit site
In SipDroid I set my username (i tried both the Gizmo phone number i got and my userid), password using my Gizmo5 info. I then put for the server:
proxy01.sipphone.com.

The dot in the top right corner of the phone is yellow, and then goes to red. I am unable to get a green light on it.

Any ideas?

My working settings (for outbound VoIP calling):
I used my Gizmo number (1-747...) in the username field.
For server I put: proxy01.sipphone.com
domain: empty
port: default (5060)
Protocol: I tried both TCP and UDP and both seem to work.

Under call options:
Use WLAN: checked
Use 3G/Edge: unchecked
Preferred call type: Sipdroid

Advanced options:
I set a ringtone
I did not set caller ID

PBXes Features:
no changes (nothing set)

Once I had it set up, I quickly got a green light. Later, however, I had a red light (503 error message) and I thought I had messed up some settings. Turns out that it was just a temporary glitch... maybe a network issue. The green light came back in a few minutes.

I tested call quality by calling in to my voice mail and listening. It sounds about as good as other test calls I have made without VoIP.
 

MountainX

Member
Nov 29, 2009
10
0
0
Visit site
The only problem I'm having is that I'm not getting incoming calls.

Solved. I'm not 100% sure what resolved the issue, but one thing I did is to remove the official Google Voice app. I think that was probably the solution.

Now I'm using Sipdroid with Gizmo and the Google Voice service, but no Google Voice app installed on the phone.

I can initiate calls using Google Voice in a browser on the phone, which keeps all calls 100% free. Incoming and outgoing calls both work over WiFi, as expected. Basically, this is a complete and working solution for me on the Droid.
 

javapop

Member
Dec 24, 2009
11
0
0
Visit site
My working settings (for outbound VoIP calling):
I used my Gizmo number (1-747...) in the username field.
For server I put: proxy01.sipphone.com
domain: empty
port: default (5060)
Protocol: I tried both TCP and UDP and both seem to work.

Under call options:
Use WLAN: checked
Use 3G/Edge: unchecked
Preferred call type: Sipdroid

Advanced options:
I set a ringtone
I did not set caller ID

PBXes Features:
no changes (nothing set)

Once I had it set up, I quickly got a green light. Later, however, I had a red light (503 error message) and I thought I had messed up some settings. Turns out that it was just a temporary glitch... maybe a network issue. The green light came back in a few minutes.

I tested call quality by calling in to my voice mail and listening. It sounds about as good as other test calls I have made without VoIP.

I'm doing everything you describe here; yet getting a 401 red light error...
 

cward0625

Well-known member
Nov 7, 2009
46
0
0
Visit site
I am not seeing how this solution works, there are still missing pieces to getting this to work in my opinion. I have got Skype to make calls via VOIP with only wifi on when I had a skype balance.

I have no balance on GIZMO, but per the above posts people are saying this is an absolutely free solution or is it not? Do you need a balance?

I have a Gizmo account and google voice.

In the steps mentioned to add Gizmo to google voice I cannot complete this step because it says it needs to call that phone and it goes to do that but my phone does not ring. So somehow I would think I need to connect my gizmo number to my cell phone, but as of right now thats not happening...

in the tutorial it does not reference the main screen. when i turn on my SIPdroid i get a box stating 'Called Party Address' under Sipdroid title. I have no idea what to do here. All my other settings match the said tutorial.

I'd be interested to get this to work, but right now I am just not connecting the dots, every tutorial I have tried to complete seems to have gaps. It would be nice for us to get a fully explained tutorial together so the inexperienced like myself can get this to work.

Thanks in advance for any help!
 

cward0625

Well-known member
Nov 7, 2009
46
0
0
Visit site
also one thing i noticed, I do not see google voice option on Gizmo's site anymore so I cannot do any of that setup. I looked on google voice's page and they have gizmo setup there which does not seem to require anything on that end, but when you try to verify the number it does not ring through to my sipdroid on my droid. I am wondering if this is something to do with the called party address field not being entered on the main screen??

very confused.
 

MikeB

Well-known member
Nov 24, 2009
107
2
0
Visit site
Is there a way to turn off SIP Droid, it just starts itself. My droid does not last a whole day from 8am to 10pm like my old storm...i have advanced task killer, but that just kills tasks when i tell it to if i am not mistaken. I would like to have an option to have it not autostart. It seems to turn on based on the setting for how many signal bars you have. Just trying to find ways to make my battery last longer.

First, its not a BB, don't use a task killer. Android manages its memory/apps fine. It will kill infrequently used apps if it needs to for low memory situations. Killing tasks will cause instability and is likely the reason people have freezes and force closes.

Second, you can see what services are running under Settings > Applications > Running Services. You can stop any services you don't want running here. They may restart when you boot the phone however.

I use this to make sure there aren't services running that I don't want. Some apps you just install will start services that run all the time, even when you don't use them. I just uninstall the app if it has a running service and I don't really use it.
 

cward0625

Well-known member
Nov 7, 2009
46
0
0
Visit site
Anyone have any help with my comments posted on 02-05-2010 in regards to linking gizmo to google voice and what to do with the SIPDroid launch screen of 'Called Party Address' box that requires input.
 

Members online

Trending Posts

Forum statistics

Threads
943,737
Messages
6,919,850
Members
3,159,199
Latest member
Hapily02