Slow charging + "Media" Battery drain

Rosenthal

Member
Jan 8, 2013
5
0
0
Visit site
Hello everyone,

In my 7 month ownership of Samsung's flagship smartphone device, I haven't been spared the annoying software (and once, hardware) issues. Now I experience one more issue, for which I hope some of you helpful folks, will assist me with what you can.
My issue probably have been discussed before, but I just don't have time to skim through lengthy topics in search for an answer. Too many post are not exactly the issue resolver and it's sort of an overwhelming experience to go through numerous topics, reading tens and sometimes hundreds opinions.
In this case I believe the solution to the issue might be something small and already known to the community at this point. Here we go:

For the last week or so I've been experiencing this battery drain, which after checking out the "battery timeline" discovered that the biggest battery hog is "Media", followed by "Android System", "Android OS", "Media Server" and "Screen" @ mere 5th place. Please, check out these screenshots: Galaxy S3 Battery Drain
Early on, in the beginning of my SGS3 ownership I was experiencing another battery drain, but then the reason was the "Mobile signal". It was unpleasant but the things went into their place after a factory reset.

And now, apart from this peculiar drain by the "Media" (which I don't have slightest idea why it occurs, since I'm not in the process of download anything) I also observe that the damn phone charges way slower than it used to. From 4% to 53% in a little over 2 (two) hours. That's annoying and unacceptable. Normally, in such a time period, the device would have been fully charged.
I had the phone rooted before, but after the jelly bean update I didn't bother.
Does anyone have any idea what is happening and what can be done to fix this. (prefereably not factory reset)

Any of your input, short or long will be greatly appreciated!
Thank you!
 

anon(973539)

Well-known member
Oct 2, 2012
188
0
0
Visit site
I had the 'Media' drain. It turns out my memory card had corrupted some of the music files on the card. As a result the phone was constantly scanning the card and draining the battery. The solution is to take everything off the card and format it. After that you can put everything back on the card. If you don't have amemory card installed then I have no idea. No idea with your charging issue, hopefully someone might be able to enlighten you.
 

Rosenthal

Member
Jan 8, 2013
5
0
0
Visit site
Thank you! This was very helpful. I indeed have a card installed (32 GB).Using isyncr I transferred some of my iTunes playlists and albums. This formatting will be a bit annoying but necessary I guess.
With all problems, wasted time + frustration this OS caused I doubt it my next phone will be running Android.
Again, thank you very much and I wait on some input about this slow charging.

Sent from my GT-I9300 using Tapatalk 2
 

flipdee

New member
Jan 15, 2013
4
0
0
Visit site
Hi everyone,
I've been experiencing the same problem with my Samsung galaxy s3, I originally suspected my sd card however after taking the sd card out the problem has resurfaced again today.
Has anyone experienced the media battery usage problem without a sd card inserted?
cheers,
flipdee
 

Rosenthal

Member
Jan 8, 2013
5
0
0
Visit site
Actually, after backing up my SD card contents and formatting it, I left it that way for a day but the problem persisted.
Today I took out the card entirely (as you did) but the issue is still present! :mad:
I guess I will have to back up with Titanium backup and do a factory reset again...

With all that time consuming problems I don't think my next phone will be Android powered.

Sent from my GT-I9300 using Tapatalk 2
 

flipdee

New member
Jan 15, 2013
4
0
0
Visit site
It is particularly annoying, I agree. However my experiences with my wife's iGadgets (iphone, ipad etc) iOS just doesn't have the flexibility, and at least there will "probably" be a fix for this problem we're having with android.
I would agree that i'm sure a media scanning/battery drain problem like this probably doesn't happen on iOS.
I'm trying to find an app to monitor things such as the media scanner, maybe logcat is the only way to properly do it?
The funny thing is I believe back in the days of my Samsung Galaxy S 1 and 2 there was a corrupt media files repair tool available, possibly in the Galaxy Toolbox app.
I probably will try a factory reset myself too, restoring my settings whilst trying to pinpoint the media scanning bug could be a pain though.
cheers,
flipdee
 

Rosenthal

Member
Jan 8, 2013
5
0
0
Visit site
Yep, that's very true. Google really made the Android experience tremendously better than the earlier versions and it's heaven for the folks that have the time, energy and desire to customize their mobile device, but these little bugging things are somewhat of a dealbraker for those that need seamless experience all the way. This "incident" isn't the first one but at least the 7th and that's a bit odd. I am guessing the pure Android experience delivered by the Nexus devices might be better but that's only an assumption. (their latest devices neatly follows iPhone's footsteps. Now SD slot, no removable battery :) )
Anyway I went completely off topic. Good luck to all experiencing this problem.
For me, reset it is.

Sent from my GT-I9300 using Tapatalk 2
 

Rosenthal

Member
Jan 8, 2013
5
0
0
Visit site
I decided to report on my results after the factory reset I did with the hope to fix the problem. Here is what came out of it:

It's actually very disappointing to see that even after the factory reset, format of the SD Card and taking out the card altogether the problem wasn't fixed in either of the attempts.

So, I did the factory reset, went through the activation process, installed all my apps again and then used TitaniumBackup to restore the data of all those apps. Then after the phone's battery was exhausted, I charged it fully to initiate the test and see if the issue is still present. Unfortunately the "Media" process is once again the top battery hogger and is the main reason behind the accelerated drain I witness on my Galaxy s3. Another thing I witness is that randomly, out of the blue I see in the notification bar that my SD card has been unexpectedly removed and then that it's ready for access again. All in all, I can access the card's contents but this notification is suspicious and probably part of the problem, but I'm almost sure that the card itself isn't the faulty one. I purchased it from reputable source and the brand is trustworthy in my opinion. The problem has to be in the phone itself.

Another thing is that after the factory reset I didn't let the phone run without any apps or restoring the app's data. Maybe I should have, since some those app's data could be in the core of this issue and TitaniumBackup might have brought it to its previous state, but I forgot to and wanted to access some of my apps' contents prior to the FactoryReset.

All in all, this problem proved to be very irritating, time consuming and unacceptable in my opinion. Maybe I should contact Samsung or the retailer that sold me the phone since it's still warranty covered, but I guess I will end up selling it and purchasing something else, probably a Nexus 4 or an iPhone (despite all the ridicule circulating about it, being a toy with limited capabilities bla bla bla... From the feedback of numerous people I know, owning iOS devises I don't know one that had issues with them that caused them that much wasted time and energy)
So that's all I had to say. I wish luck to anyone else experiencing the same problem and take care!
 

anon(973539)

Well-known member
Oct 2, 2012
188
0
0
Visit site
Try a different memory card, or no card at all Media Scanner should stop altogether once the card is removed. Also if you check the forums you will see people talking about the S3's tendency to 'fry' perfectly good memory cards, you may have bought the card from a trusted seller, however your phone may have trashed it.
 

flipdee

New member
Jan 15, 2013
4
0
0
Visit site
My only problem is the media processes are still taking up about 30 mins of cpu/wake time every day for me and that's without the sd card inserted.
Do we know which actual process is causing the problem? Is it media storage?
Cheers,
flipdee

Sent from my GT-I9300 using Tapatalk 2
 

CaneToad

Well-known member
Jun 19, 2012
141
5
0
Visit site
Mine started doing the exact same thing last week since I started getting the "sd card removed unexpectedly error" If I remove the card completely there is no problem. I formatted the card and it semed to be better till I installed my music now its doing it again.
 

CaneToad

Well-known member
Jun 19, 2012
141
5
0
Visit site
Ok I am now trying another SD card with only a few songs on it, I still get Media showing up in the battery drain list but its now only 6% or so. Pretty happy that its not a faulty SD Card. Hopefully there is a fix for this.
 

Tony Hunt

New member
Feb 4, 2013
2
0
0
Visit site
I had the 'Media' drain. It turns out my memory card had corrupted some of the music files on the card. As a result the phone was constantly scanning the card and draining the battery. The solution is to take everything off the card and format it. After that you can put everything back on the card. If you don't have amemory card installed then I have no idea. No idea with your charging issue, hopefully someone might be able to enlighten you.

Thanks Gwappa. I was getting really frustrated with my battery time. I could see it was the media drain. I would kill the task but it comes back constantly. You can almost just watch the battery go down say 30% just on a 45 minute train ride. I finally just deleted all of my music and the mediainfo.xml file manually from the SD Card. I didn't bother with the format. Then I just copied the few albums back that I want, 200 songs, not 1400. At first I thought the media drain had come back, then it stopped after 60 minutes or so which is safe to say it was processing the media once as you would expect.

Together with JuiceDefender, I'm now getting a solid / repeatable 25 hrs out of the battery which is more than enough... and that's me fiddling on it all day with web browsers, RSS, email.
 

morgangdfp

New member
Apr 6, 2013
1
0
0
Visit site
Nothing of what you all suggested worked for me.. I have now removed all my music as well as removed the SD card and still media is draining my battery.. I installed GSam battery monitor and from there it appeared to be "Downloads" that was the main culprit. I force stopped that process from application manager and now my battery is normal again.
Downloads will start up again after a reboot so I guess I just have to kill it again everytime..
Does anyone think that a factory reset would be a better solution.. I am afraid to do that because then I will loose all my 4 pics 1 words..
 

flipdee

New member
Jan 15, 2013
4
0
0
Visit site
Download rescan media root from Google play and disable media scanner (you need to have rooted your phone)
That worked for me.
Cheers
flipdee

Sent from my GT-I9300 using Tapatalk 2
 

CaneToad

Well-known member
Jun 19, 2012
141
5
0
Visit site
I had this problem with a 32gb sandisk card even after formatting the card. I put it in my fathers Acer tablet where it works perfectly and put a spare 8gb card in my S3 its been a couple of months now without a problem.
 

Jason Bosch

New member
May 22, 2013
2
0
0
Visit site
I had the same issue, except before the latest Android update on Verizon, it just said "Media" was using all of my battery. Much more than the screen even! All the time. After the update, the Media changed to Gallery, which gave me the clue that the Gallery was causing the issue. I had already tried disabling the Picasa sync, and that didn't fix the issue. I had also tried disabling about 50 other things and could never find the problem. I just couldn't get the draining to go away.

As a last ditch effort, I tried Disabling the entire Gallery App. Not just stopping it, clicking "Disable" in the Gallery app settings. Sol ed the problem instantly. If you don't already, you should totally be using the QuikPic app as your photo gallery since it's waaay faster and better than Samsung's gallery. The only problem is that the default camera app only uses the stock gallery app, so you can't quickly view your photos after you take them. But I found a better camera app in ProCapture anyhow. The panoramic and customizations are way better. So I just use that now.

Also lost my picture frame widget, which I loved. But worth it to not have a dead phone anymore. If anyone knows a good photo frame app, I'd love to hear about it. I couldn't find a comparable one, despite a lot of searching.

Hope this helps someone!
 

Romke Kats

New member
May 25, 2013
3
0
0
Visit site
As for the Slow charging problem. Try using another USB cable. Some USB cables cannot deliver the high charge current for the S3. This solved my slow charging issue.
 

Latest posts

Trending Posts

Forum statistics

Threads
946,057
Messages
6,926,195
Members
3,160,058
Latest member
skylarktg