Slow loading (stalling) of Pictures on Instagram over 4G LTE?

wootang00

Well-known member
Jun 2, 2010
63
1
0
Visit site
Hello,

I used to have an Galaxy S3 and on Instagram I would have pictures load up very quickly.
I picked up a Galaxy S4 and for some reason I have a hard time loading pictures over 4G LTE.
I will do a speedtest and I am getting great speeds. Avg anywere from .. 6 to 15mbps down

Does anyone else have a problem of the pictures loading VERY slowly on 4G LTE? or sometimes where it goes half way and says "cannot load.. retry"?
It's almost like it starts to grab the picture and the connection cuts off half way.. and it stalls out. One way I can test this is go to Explore.. and i'll wait a minute or two sometimes for the pictures to show up 100%.. normally the pictures show up within seconds. That said.. its sporadic at times.. sometimes works well sometimes not.

Just an FYI.. when i put the phone on WiFi.. it loads up quickly with no issues
If you could respond with your experience.. on your Galaxy S4 on 4G LTE w/ instagram pic loading.. (test on "explore").. id appreciate it!

Thanks!
 

xxtdxx

Well-known member
May 23, 2011
82
3
0
Visit site
I have the same issue. S4 and it takes forever to load pictures...if they ever load at all.

Sent from my SCH-I545 using AC Forums mobile app
 

Almeuit

Moderator Team Leader
Moderator
Apr 17, 2012
32,277
23
38
Visit site
It may be the app. Try the instagram mobile site and see how it is.

Sent from my T-Mobile HTC One using AC Forums.
 

kevintstephens

New member
Jan 9, 2011
1
0
0
Visit site
Having the same problem on my Droid Razr Maxx. Just started happening the last few days. From the sounds of it, it may be a network issue. I hope they get it soon, because Instagram and Facebook are significantly less interesting without photos.
 

Arlyn LuvUpa

New member
Feb 9, 2014
1
0
0
Visit site
I have the same problem about loading but the other way around, its much faster when I am on 4G and slow on wifi, i already checked the router and it's working perfectly fine with others. so i am thinking is it maybe because of my phone?
 

Forum statistics

Threads
943,976
Messages
6,920,877
Members
3,159,336
Latest member
amitmisir