SOLVED: Can phone drops cause occasional hardware glitches to Hotspot out or cell data in?

Madd62

Mr. Wonderful
May 31, 2021
265
189
43
Visit site
Streaming to an older large TV from a PC via a HDMI cable using wireless phone tethering / hotspot.

Last two weeks I now get an occasional but regular sudden signal loss to my pc/TV, every 30 - 60 minutes roughly.

I have dropped my heavy phone a few times recently from no more than 2 - 3 feet.

It's well protected with tempered glass and a Spigen case, but it's heavy at 220 gms and it can make a loud thud on light carpet over wood, or on hard flooring, so I'm wondering if internal shocks could displace something.
 
Last edited:

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,981
5,288
113
Visit site
Could it possibly be a throttling thing? Do you have unlimited high speed tethering, or is there a monthly limit before it gets throttled?
 
  • Like
Reactions: Madd62

Madd62

Mr. Wonderful
May 31, 2021
265
189
43
Visit site
Thanks. No I have full tethering on a 160 gb plan for 4 years.

I have considered other possibilities, like a local network problem or construction but they don't apply for when using my phone screen only; plus I do also have an old laptop tethered for pc stuff some of the time, and that also loses the network.

It may be something else, but it would be good to know if it's just my old Poco. I have tried switching between 4G and 5G in Settings but same thing.

Oddly this model has only 2 5G bands, N77 and N78 iirc, but it has always worked well.
 
Last edited:

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,981
5,288
113
Visit site
Any new wireless devices in the house that might be interfering with whatever wi-fi band/channel that the tethering is using?
 
  • Like
Reactions: Madd62

Madd62

Mr. Wonderful
May 31, 2021
265
189
43
Visit site
I don't think so.

I'm the sole remaining occupant of the building my flat is in. The owners have a router running since some renovation started at least 18 months ago that I've never logged in to, so that has never been a factor. It's showing as a strong but locked network.

I'll hope this stops happening. It may be external.

Perhaps coincidentally a few heavy thuds from drops made me wonder if something happened to the phones motherboard.

I also stupidly realised I could put my high data sim in to my secondary single sim Moto E6 for a few hours in the evening to use it's Hotspot and see if the lost connection recurs then.

🤔 👍🙃
 
  • Like
Reactions: B. Diddy

Madd62

Mr. Wonderful
May 31, 2021
265
189
43
Visit site
SOLVED:
I found a new setting under Battery - Additional features which I probably discovered in the correct time frame, experimented with it and then forgot.
I thought I had checked through everything again, but guess I hadn't.
Seems it would turn off data after 30 minutes sleeping, but as soon as I lift or open my phone the data signal thingy starts to reappear. Hence my Hotspot streaming got disconnected.
It didn't seem like every 30 minutes but I probably looked at the phone occasionally so the intervals were erratic.

Xiaomi still seems to send features, and updates Settings, even though I won't get a MIUI OS update or any more Security patches on my nearly 4 year old phone.

Everyone stand down! Job done!


========

And as it's set now :

Like my new Device Frame feature in the correct colour? 😊
 

Attachments

  • Screenshot_2024-05-16-21-06-31-309-edit_com.miui.securitycenter.png
    Screenshot_2024-05-16-21-06-31-309-edit_com.miui.securitycenter.png
    231.5 KB · Views: 5
Last edited:

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,981
5,288
113
Visit site
Great, thanks for sharing your solution! It will probably be pretty helpful for others facing the same issue.
 
  • Like
Reactions: Madd62