Question Specifically the phone ringer volume setting itself to zero!

Paulxxxxx

Member
May 18, 2019
10
2
3
Visit site
Hi all,

I have various modes on my phone (Sleep, with Do Not Disturb within that) BUT, I don't think that's the issue (or shouldn't be), as Sleep ends at 7am.
My problem is that the phone ringer volume for incoming calls keeps setting itself to zero - I missed 3 urgent calls from the police this morning at 10am, which is why I'm here! (BTW it's frustrating as I can't call them back...). Why is this happening and, more importantly, how can I stop it happening (apart from spending half my waking hours checking that the volume's up haha)?

Thanks for any tips and tricks. I'll check back here throughout today and this week.

Best wishes
 
Last edited:

VidJunky

Well-known member
Dec 6, 2011
5,630
434
83
Visit site
So are you having to check multiple times a day to see if the volume is still correct or were you being factious and just saying you don't want to do that? Until you said "checking it all day" it sounded like you were only having issues when sleep mode ended .

How are you putting it in sleep mode? Are you saying that DND is your sleep mode or are these two different things that happen together?

How do you activate DND? Do you have it set to a schedule, you manually turn it on after Night Court, it's part of another mode or app you're using?

Have you skipped a night of DND to see if everything acts normally? Or if all of this happens automatically have you manually ended sleep mode/DND, did it still happen?


While of course solving this is the goal but perhaps you could use Bixby to build a routine that turns the volume on/up at a certain time or with some other trigger. Tasker is another automation app that could do this but it is a paid app and has a learning curve and can do so much more. Just depends on how much you want to learn and use basic programming logic. Bixby should work though. Tell us a bit more and maybe we can pin down the issue.
 

Paulxxxxx

Member
May 18, 2019
10
2
3
Visit site
Hi VidJunky, thanks for responding,

I would need to check my phone multiple times a day to ensure that I don't miss calls, but I don't actually do this, which is why I miss the calls quite often.

About the routines, I have Sleep set at a regularly scheduled time (22.40 to 6.40), and within the Sleep routine settings, you can opt to have Do Not Disturb as part of that routine. (Other features of Sleep are that your icons and screen are grey (optional), and you can block yourself from using apps if you wish too.)

Perhaps my mention of the Sleep routine was a bit redundant (but I was just trying to eliminate it as a cause of the problem). I was having this issue before I set that routine also, and I'm presuming that it's not the cause of the issue.

Looking hopefully for some setting within Android that lets me set incoming calls to loud volume as a default, ideally. (Of course I still wouldn't be disturbed by calls at all during times when the Do Not Disturb was set to On.)

I may have to experiment with the Do Not Disturb settings, as you suggest, in case this is basically messing up the normal phone settings somehow. Just to clarify, the phone is setting itself to silent for incoming calls even if Do Not Disturb is off.
 

B. Diddy

Senior Ambassador
Moderator
Mar 9, 2012
165,766
4,965
113
Visit site
Welcome to Android Central! This is probably a silly question, but can you confirm that you're looking at the Ring Volume slider and seeing that it's turned all the way down? I just want to make sure it's not a case of the phone automatically screening the call and making it go straight to voicemail, rather than the Ring Volume slider being set to silent.
 

Paulxxxxx

Member
May 18, 2019
10
2
3
Visit site
Hi B. Diddy, yes, it's the slider down to zero volume.
As of tonight I've deleted the Sleep routine, as Do Not Disturb will do for sleeping (scheduled to turn on from 22.00 to 7.00)
Just to note, this problem has been happening for years, with various Samsung phones that I've had.
 
Last edited:
  • Like
Reactions: B. Diddy

Paulxxxxx

Member
May 18, 2019
10
2
3
Visit site
So are you having to check multiple times a day to see if the volume is still correct or were you being factious and just saying you don't want to do that? Until you said "checking it all day" it sounded like you were only having issues when sleep mode ended .

How are you putting it in sleep mode? Are you saying that DND is your sleep mode or are these two different things that happen together?

How do you activate DND? Do you have it set to a schedule, you manually turn it on after Night Court, it's part of another mode or app you're using?

Have you skipped a night of DND to see if everything acts normally? Or if all of this happens automatically have you manually ended sleep mode/DND, did it still happen?


While of course solving this is the goal but perhaps you could use Bixby to build a routine that turns the volume on/up at a certain time or with some other trigger. Tasker is another automation app that could do this but it is a paid app and has a learning curve and can do so much more. Just depends on how much you want to learn and use basic programming logic. Bixby should work though. Tell us a bit more and maybe we can pin down the issue

Thanks for the ideas but I'm really just looking to solve the specific issue of not hearing incoming calls due to the volume down issue.
 

mustang7757

Super Moderator
Moderator
Feb 6, 2017
91,890
6,450
113
Visit site
Hi, sorry I forgot to mention - it's a Samsung S20 5g Ultra
Thanks and for clarification your adjusting the ring volume not the media volume? By default Samsung has Media volume set first I'll show example
Make sure this is toggle off otherwise it may seem your adjusting the volume when u are only adjusting the media
b35621ce88b04a4c92ff0f9fc9e25ca9.jpg
8947e6ebe58a7e7aa2a0018fe7488103.jpg
 

Paulxxxxx

Member
May 18, 2019
10
2
3
Visit site
Hi Mustang7757,
I do appreciate that you've taken the time to explain this.
Since this occurrence is so random and I can't really explain why it happens I think it may be unlikely to get to the bottom of it on this thread and I feel a bit guilty because everyone's made such an effort to try to help!
Seems a shame that on the rare occasions one actually gets a call nowadays (since mostly my family, friends, and work use WhatsApp, Teams, Messenger etc etc) the phone no longer does it's core function properly! (Or some setting has gone awry which may or may not be from my use of the modes and routines which somehow confuses the phone into going silent)
It was very lucky that I got an email from the police giving me a direct line number to call them back because the number they phoned me on, you couldn't call it back.
I'll probably have to just make a habit of checking that my call volume is up on a more regular basis. However I'm loath to leave the phone on the whole time in case my precious sleep is disturbed!
Thanks to everyone again for the time you spent trying to help me out.
 
  • Like
Reactions: mustang7757

mustang7757

Super Moderator
Moderator
Feb 6, 2017
91,890
6,450
113
Visit site
Hi Mustang7757,
I do appreciate that you've taken the time to explain this.
Since this occurrence is so random and I can't really explain why it happens I think it may be unlikely to get to the bottom of it on this thread and I feel a bit guilty because everyone's made such an effort to try to help!
Seems a shame that on the rare occasions one actually gets a call nowadays (since mostly my family, friends, and work use WhatsApp, Teams, Messenger etc etc) the phone no longer does it's core function properly! (Or some setting has gone awry which may or may not be from my use of the modes and routines which somehow confuses the phone into going silent)
It was very lucky that I got an email from the police giving me a direct line number to call them back because the number they phoned me on, you couldn't call it back.
I'll probably have to just make a habit of checking that my call volume is up on a more regular basis. However I'm loath to leave the phone on the whole time in case my precious sleep is disturbed!
Thanks to everyone again for the time you spent trying to help me out.
No worries we don't mind to help.
I can let you explore a little more and see if these setting's reset might help if you like to try when u have time .

1. Settings>apps>3 dots upper right corner tap>select reset app preferences might undo anything app related.

2. Settings>general management>reset>reset settings this I've seen fix some mystery glitches.

I would say try safe mode but no red party apps work until you exit out (Restarting phone)but might be worth a shot.

Also don't know if mentioned have you rebooted your device? Sometimes that helps with glitches
 

Paulxxxxx

Member
May 18, 2019
10
2
3
Visit site
Thanks for those suggestions - worth a try!
Quite recently I actually did a full factory reset but that was for a different problem - caused maybe by a sleep recording app that I got rid of during the reset.
Just now I checked the incoming call volume and it was down again and I noticed that Do Not Disturb was on so I think this is clearly the culprit: Do Not Disturb coming on random times, rather than any of the volume settings.
I think it might be better not to have an actual schedule for Do Not Disturb, but just to turn it on before I go to sleep and then turn it off when I wake up.. The trouble with having any schedules it seems is that if you then override them at any point the phone seems to get confused, or rather it will just then leave Do Not Disturb on continuously. Just my guess.
 
Last edited:

mustang7757

Super Moderator
Moderator
Feb 6, 2017
91,890
6,450
113
Visit site
Thanks for those suggestions - worth a try!
Quite recently I actually did a full factory reset but that was for a different problem - caused maybe by a sleep recording app that I got rid of during the reset.
Just now I checked the incoming call volume and it was down again and I noticed that Do Not Disturb was on so I think this is clearly the culprit: Do Not Disturb coming on random times, rather than any of the volume settings.
I think it might be better not to have an actual schedule for Do Not Disturb, but just to turn it on before I go to sleep and then turn it off when I wake up.. The trouble with having any schedules it seems is that if you then override them at any point the phone seems to get confused, or rather it will just then leave Do Not Disturb on continuously. Just my guess.
Maybe try without DND see if issue still happening to rule it out
 
  • Like
Reactions: Paulxxxxx

Trending Posts

Forum statistics

Threads
943,906
Messages
6,920,595
Members
3,159,296
Latest member
Lethabo Mokoena