Sprint One M9 Lollipop 5.1 No Vibrate

grizzlyaddams

Active member
Jun 8, 2010
42
0
0
Visit site
So I recently got the Lollipop 5.1 update on my Sprint HTC One M9. Generally happy with the phone and the update seemed to have gone fine.

I can't say for sure if the vibrate motor was working right after the update. But as of today it is definitely not working. Not for calls or notifications and not for screen touches either if enabled.

I don't and haven't dropped the phone. It hasn't gotten wet. If I run the diagnostics on the phone for the vibrator, the motor does not come on.

However, if I restart the phone normally from the power options, the motor does briefly vibrate as expected. It does this consistently each time I restart it. Therefore I do not think it is physically damaged.

I do use the vibrate at work so I can keep the phone silent in my pocket but still know when my wife or kids are trying to get ahold of me. It will be very inconvenient if I cannot resolve this.

Anyone have any ideas?

Thanks!
 

Rukbat

Retired Moderator
Feb 12, 2012
44,529
26
0
Visit site
It could still be a defective vibrate motor, or it could be a defective update. I'd take it to the carrier and ask if they could reflash the update. (Back everything up first - see Backing up an Android Device - they may decide to flash a whole 5.1 ROM.)
 

grizzlyaddams

Active member
Jun 8, 2010
42
0
0
Visit site
Okay nevermind. It appears they changed the way that Power Saver mode works, and though it wasn't happening originally, when the phone hit 15% recently it turned on Power Saver automatically, and kept it on indefinitely, which appears to disable the vibrator from all sources.

Which is a bit of a shame because previously in 5.02 I had left Power Saver mode on all the time, which helped my battery life a lot, but my vibrate still worked.
 

brooke006

New member
Jul 30, 2015
2
0
0
Visit site
I'm so glad I found this thread. It brought to my attention the battery saver feature on my M9. Once I got the new update on Sunday, my phone wouldn't vibrate for texts but it would for phone calls, so I knew there was nothing wrong with the motor. I called Sprint twice and went into two Sprint stores but no one could offer a solution.
I just turned off the battery saver in my settings and now I'm getting vibrations for all activity. I'm relieved, but hope they fix this bug, because I like keeping my phone on battery saver 24/7.
Hope this helps anyone else who can't figure out why their phone stopped vibrating.
 

neo905

Well-known member
Apr 4, 2014
1,117
0
0
Visit site
The more I hear about the new way Power Saver is implemented in 5.1 the less I want it. Why on earth would HTC think an all or none solution as far as checking off which items you want in power saving mode is a good idea. Now this. It isn't even a bug. It is a stupid conscious decision.

Posted via the Android Central App
 

ram1220

Well-known member
Oct 15, 2013
319
0
0
Visit site
The more I hear about the new way Power Saver is implemented in 5.1 the less I want it. Why on earth would HTC think an all or none solution as far as checking off which items you want in power saving mode is a good idea. Now this. It isn't even a bug. It is a stupid conscious decision.

Posted via the Android Central App

This is one of the reasons I am perfectly happy with my M7. I still have Kit Kat on it and I refuse to put Lollipop on it.
 

puch96

Well-known member
Nov 27, 2012
879
30
28
Visit site
Okay nevermind. It appears they changed the way that Power Saver mode works, and though it wasn't happening originally, when the phone hit 15% recently it turned on Power Saver automatically, and kept it on indefinitely, which appears to disable the vibrator from all sources.

Which is a bit of a shame because previously in 5.02 I had left Power Saver mode on all the time, which helped my battery life a lot, but my vibrate still worked.

If you go under power saving settings, you had a list of things to check to conserve battery in 5.0.x. Do you still have those settings? maybe there is a setting to avoid turning off vibration.
 

Bildriver

Well-known member
Jan 14, 2016
115
0
0
Visit site
No vibration. Noticed while taking volume up and down that it was shutting off before it was supposed to vibrate. That's correct but power saver was off also. So long shot time, removed my Otterbox, bingo I got vibrate back. All I can figure was the Otterbox button(s) were holding some thing down. Oh well, long shot payed.

Posted via the Android Central App
 

Members online

Forum statistics

Threads
941,453
Messages
6,908,946
Members
3,157,929
Latest member
AMPRO