Stock music player and Google Player bluetooth title issues

OhAlfie

Well-known member
Sep 30, 2012
868
11
18
Visit site
I'm stumped. Ever since day one with this phone (which I love) I can't get the title/artist track names to show up correctly on my year old Kenwood car receiver. When I play a track, it may show the artist/title, then when I hit the skip button, the previous tracks title/artist name stays locked on the screen. If I keep hitting FF, it will eventually change to the new songs info. Note that the FF button works fine and the sound is fine. Same exact issues when using the Google Music Player.

I figured when KitKat came it would fix things, no such luck. At first I thought it was my radio, then I started to download various players like Rocket, etc. The Rocket one worked fine prior to KK, now it's all jacked up after the update. I tried PowerAmp and it did ok for a while, but then started acting up too.

This week I downloaded the N7 player and it works perfectly. All track info displays perfectly..no lag etc. Problem is I hate the players layout etc. I much prefer using the stock player since I have the Quickview case and the music screen is part of the set up.

So what the heck is going on? Am I the only one with this odd issue? Again I can't figure out why some players work perfectly and the main ones I prefer to use just suck at the BT data info.

Any suggestions as to what to do?

Note that my Kenwood firmware is up to date per Kenwood tech.
 

Forum statistics

Threads
943,026
Messages
6,916,955
Members
3,158,788
Latest member
sadexk