Stop alarm from playing thru speaker when headphones are plugged in

rabiddog99

Member
Jun 13, 2013
11
0
0
Visit site
Is there any way to stop the alarm from playing music thru the speaker when the headphones are plugged in? I don't want the whole office to hear my alarm go off. I had the same problem with my Note 4 and never figured out how to fix it.

Also for some reason if I lay the phone face down, I can not turn the alarm off or snooze it using the buttons, I have to pick the phone up or lay it face up to turn alarm off or snooze it.

Thanks
 

SpookDroid

Ambassador
Jul 14, 2011
19,343
623
113
Visit site
That's because it's not a problem/bug...just not a feature you can turn off. You'd have to download a Clock app that supports that (if there is any... the only ones I know of play alarms through the phone's speakers because most of the time you can fall asleep with headphones plugged in but still need to wake up in the morning...)

For the 'facing down' issue, try disabling the feature to snooze/dismiss alarms by flipping the phone down.
 

SpookDroid

Ambassador
Jul 14, 2011
19,343
623
113
Visit site
In that case you might have to disable the 'lock in dark places' feature. In theory that's for the screen, so not sure if it affects hardware buttons too, though, but worth a try.
(Settings, Display, Block accidental touches)
 

anon(3641385)

Well-known member
Sep 2, 2016
504
0
0
Visit site
Is there any way to stop the alarm from playing music thru the speaker when the headphones are plugged in? I don't want the whole office to hear my alarm go off. I had the same problem with my Note 4 and never figured out how to fix it.

Also for some reason if I lay the phone face down, I can not turn the alarm off or snooze it using the buttons, I have to pick the phone up or lay it face up to turn alarm off or snooze it.

Thanks

What music app are you using?

My podcast app, antenna pod, has controls for what I think you might mean, so I'm guessing that your music app may as well 🤔
 

Attachments

  • 5411.jpg
    5411.jpg
    32.2 KB · Views: 11

anon(3641385)

Well-known member
Sep 2, 2016
504
0
0
Visit site
Also, maybe there's a feature in Accessibility re controlling alarm features like turning it off or snooze 🤔
 

Attachments

  • 5412.jpg
    5412.jpg
    27 KB · Views: 7

rabiddog99

Member
Jun 13, 2013
11
0
0
Visit site
In that case you might have to disable the 'lock in dark places' feature. In theory that's for the screen, so not sure if it affects hardware buttons too, though, but worth a try.
(Settings, Display, Block accidental touches)

This was already on, are you saying turn it off?
 

rabiddog99

Member
Jun 13, 2013
11
0
0
Visit site
Heavens1

When my headphones are plugged in my music, my phone, everything with sound goes thru my headphones. It's only when my alarm goes off does the sound go thru both my headphones and phone speaker at same time. I'm wanting sound thru headphone and not phone speaker when my alarm goes off, so my alarm doesn't annoy my coworkers in the office.
 
Last edited:

SpookDroid

Ambassador
Jul 14, 2011
19,343
623
113
Visit site
Heavens1

When my headphones are plugged in my music, my phone, everything with sound goes thru my headphones. It's only when my alarm goes off does the sound go thru both my headphones and phone speaker at same time. I'm wanting sound thru headphone and not phone speaker when my alarm goes off, so my alarm doesn't annoy my coworkers in the office.

Yeah, that one is NOT possible unless the alarm app you use supports something like that (I don't know of any that do). Reasoning behind this in the first few posts.

As for the Block Accidental Touches, yes, turn that off and see if that helps with you being able to dismiss the alarm when the phone is flipped down. Again, might not do anything since that option is supposed to block the display input and doesn't mention hardware buttons, but it's worth a shot.
 

rabiddog99

Member
Jun 13, 2013
11
0
0
Visit site
Originally Posted by SpookDroid In that case you might have to disable the 'lock in dark places' feature. In theory that's for the screen, so not sure if it affects hardware buttons too, though, but worth a try.
(Settings, Display, Block accidental touches)

This worked for laying the phone on its face at night and being able to use the buttons to snooze, Thanks