Stop Auto connecting to open wifi

dr_fone

New member
Feb 27, 2016
4
0
0
Visit site
I was having a lot of problems with auto connecting to open wifi networks

Basically been working at same place for years, so had the same journey in to work on the tube (or the subway if you're in the States!) and when I had my iPhone or my Nexus with pure Android, I could stop connecting to unknown networks. But since I bought my S6 Edge+, its been very irritating because there's so many BT Openzone networks that my phone was automatically connecting to and the only way was to switch off my wifi. The problem is when I get home and I've forgotton, it burns through my monthly data allowance when I'm watching movies on my phone.

So....

What you do is when you phone connects to an open network, go to Settings > WiFi and select the network you have connected to, press and hold to go into advanced settings / Manage network settings and for the network, select Static IP, and put in a static IP and subnet mask (something like 19.8.2.5 and 255.255.0.0). Once you save this, you phone will try to use a specific IP for that network, and it won't work. So you phone can't connect.

This won't affect connecting to your network at home, it will only be with the annoying open networks that your phone keeps trying to connect to.
You will however need to do this for every network on your journey that you auto connect to

Hope this helps someone!
 

DenverRalphy

Retired Network Mod
May 11, 2010
518
54
0
Visit site
Have you tried going to Settings - WiFi - More (top right corner) - Advanced, then turn off Passpoint connections? Your device should only automatically connect to Passpoint Certified WiFi networks. And if you turn that option off, you won't automatically connect to any Wifi network.
 

tardus

Well-known member
May 26, 2014
1,273
0
0
Visit site
IMO connecting to unsecured wireless networks is not a good idea. I unchecked on my LG G4. It should also reduce battery consumption a little.