Stuck at Fastboot & Rescue Mode, tried multiple things; Always 100% Original Software

richh008

New member
Feb 2, 2019
1
0
0
Visit site
Hi reader,

First some background:
A month ago I changed my SIM Card in my 2.5 year old Huawei P9 Lite with original Android 7.0. I never flashed or rooted this phone. Developer options are on (not sure though). Since then, I saw a major battery drain. After charging fully, it drained fast to 51% and got stuck on 51%. The phone turned off. After trying to turn it on, the red LED flashes. Charging it for 2 days, the green led turns up. However, turning the phone one, the screen stays black and red light flashes. Charging for 5-10 minutes, the green light turns on but this loop of green and red lights continues.

What I want:
Get my contacts and notes back

What I tried:
- Volume down + power and connecting to pc -> Fastboot. Message:
* Please connect usb cable to your computer and open HiSuite -> done, but HiSuite does not recognize phone. Windows does, as Android Sooner Single ADB Interface. The cmd code: ''fastboot'' does not give the wanted result (not found). As windows does not recognize the correct phone, I tried to install a new Huawei USB driver. The problem is, that Windows says the Android Sooner driver is already the best driver available.
* Android reboot reason: AP_S_COLDBOOT NA. Volumekey_down_press_process_func
* Green android puppet
* PHONE Locked. FRP Lock. -> I tried to unlock via Universal Fastboot & ADB Tool. This program recognices device as ''FUH4C16518004949 fastboot'' and reboot button in the program phone works (but again the red light). I also tried to unlock bootloader but I cannot find the correct key via the Huawei website (thus could not try oem relock *Here Huawei Code*). I tried to flash EliteTWRP-3.2.1-0_2018-01-19.img, but that is not possible due to the lock.

What can I do next in order to get a backup of my contacts and notes?

Phone will go on charger again.