Stuck on 3G after Jelly Bean upgrade!

tlehmann

Well-known member
Aug 15, 2012
73
0
0
Visit site
I frequently used the app Phone Info on my Galaxy S3 to switch to 3G when I needed to save battery life. On Friday I had the phone set to CDMA Auto (PRL) and was connected to WiFi. I downloaded and installed the Jelly Bean update only to realize a day later that my phone was still on 3G. I launched Phone Info to enable LTE/CDMA/EvDo and then closed the app to continue my web browsing, but 3G was still enabled. I closed Phone Info from the task manager then launched it again to find that the CDMA Auto (PRL) option was selected again. No matter how many times I select the LTE network, the phone simply won't connect. The 3G connection never goes away, either, no it's like it's not even trying. Is this something that is going to require a factory reset, because I am really trying to avoid that.
 

ttrimmer

Well-known member
Sep 5, 2011
156
9
0
Visit site
I had the same exact issue so I went into settings and mobile networks and changed it in there. It worked perfectly.

Sent from my SCH-I535 using Android Central Forums
 

NotJustAPhone

Well-known member
Jan 29, 2011
5,374
734
0
Visit site
The phone won't enable LTE unless you select the LTE/CDMA option under Settings/More settings/Mobile network.

So, use Phone Info to put the phone in 3G, but use settings to switch back to LTE (no need to change the settings using Phone Info).

Sent from my SGSIII
 

cmgodwin

Active member
Apr 26, 2012
31
0
0
Visit site
The phone won't enable LTE unless you select the LTE/CDMA option under Settings/More settings/Mobile network.
So, use Phone Info to put the phone in 3G, but use settings to switch back to LTE (no need to change the settings using Phone Info).

Sent from my SGSIII

I was having a similar issue. First mine was stuck on GLOBAL which seemed to draining the battery even when I was charging it. Then it was somehow stuck on CDMA Auto (PRL). I found the PREFERRED NETWORK MODE setting { Settings >>More settings >>Mobile Networks >> Network mode} and switched it to LTE/CDMA and the issue appears resolved now.
 

xfullboost

New member
Aug 31, 2012
3
0
0
Visit site
Thank you so much!!! :)


I about had a heart attack over the past hour thinking my phone was ruined.

I guess the phone info app is useless with jelly bean
 

riot1002#AC

Well-known member
Oct 9, 2010
92
0
0
Visit site
tried that..I spoke to verizon and they tried a few things that did not work.The last thing they wanted was a factory reset.I declined that.I will lose alot of stuff and it is no gurantee it works.Looks like I am stuck with 3g .My phone was perfect before this update.
 

Trending Posts

Forum statistics

Threads
945,802
Messages
6,927,192
Members
3,159,971
Latest member
rj3005